Jump to content
You must now use your email address to sign in [click for more info] ×

Merge With Hyperlink No Longer Working!


Recommended Posts

***UPDATE***

I was able to resolve the issue. Previous versions let me use the information in my column in Excel without issue but this latest version requires that the column be in the web address form. It sucks because now I have to change all of my excel sheets but the function itself still does what it should do.

I am using the latest Beta (2.3.0.2114) and I have lost the ability to create a merge field with my hyperlinks. It worked in previous versions but now it keeps telling me that it cannot open the PDF viewer when it is supposed to open an external link. Is anyone else having this problem?

Edited by TPG
FIXED!
Link to comment
Share on other sites

21 hours ago, TPG said:

I am using the latest Beta (2.3.0.2114) and I have lost the ability to create a merge field with my hyperlinks. It worked in previous versions but now it keeps telling me that it cannot open the PDF viewer when it is supposed to open an external link. Is anyone else having this problem?

Hi @TPG,

Were you experiencing the issue on Mac or PC and which PDF Reader were you using?

Affinity Designer 2.4.0.2301 | Affinity Photo 2.4.0.2301 | Affinity Publisher 2.4.0.2301
Affinity Designer 1.7.3 | Affinity Photo 1.7.3 | Affinity Publisher 1.10.8
MacBook Pro 16GB, macOS Monterey 12.6.8

Link to comment
Share on other sites

29 minutes ago, Hangman said:

Hi @TPG,

Were you experiencing the issue on Mac or PC and which PDF Reader were you using?

I am using a Windows PC with win 11 pro. I have Adobe Acrobat but my issue was not about PDF. I can create, and read, PDFs exported from Publisher. The problem was with how it deals with my hyperlinks now. In previous versions I was able to point to a cell that had a hyperlink but showed text and it would still direct me to the hyperlink. Now it just gives me the text and when I try to open the link after generating my page, it gives me a pdf error on the hyperlink.

Link to comment
Share on other sites

  • Staff

Hi @TPG
I've tried to recreate this based on what you are saying in the latest beta build and in 2.2.1 release, however in both versions only the text is copied over and not the hyperlink.
Could you provide an example document and a screen recording of this issue in action so we can get some clarity on what you are seeing? In which build were you previously able to import a hyperlink from a excel file via data merge? 

Link to comment
Share on other sites

21 minutes ago, TPG said:

I am using a Windows PC with win 11 pro. I have Adobe Acrobat but my issue was not about PDF. I can create, and read, PDFs exported from Publisher. The problem was with how it deals with my hyperlinks now. In previous versions I was able to point to a cell that had a hyperlink but showed text and it would still direct me to the hyperlink. Now it just gives me the text and when I try to open the link after generating my page, it gives me a pdf error on the hyperlink.

Thanks for the clarification... I've just been testing this in 2.3.0.2114 on macOS and I'm not seeing any issues but I may well be missing some of the specific details in terms of how your Publisher and/or excel file is set up... if you are able to upload even a simple sample where this is happening that would be really helpful...

Affinity Designer 2.4.0.2301 | Affinity Photo 2.4.0.2301 | Affinity Publisher 2.4.0.2301
Affinity Designer 1.7.3 | Affinity Photo 1.7.3 | Affinity Publisher 1.10.8
MacBook Pro 16GB, macOS Monterey 12.6.8

Link to comment
Share on other sites

59 minutes ago, EmT said:

Hi @TPG
I've tried to recreate this based on what you are saying in the latest beta build and in 2.2.1 release, however in both versions only the text is copied over and not the hyperlink.
Could you provide an example document and a screen recording of this issue in action so we can get some clarity on what you are seeing? In which build were you previously able to import a hyperlink from a excel file via data merge? 

Here is a screen shot of the file I was working with. As you can see, I have a column for the link and then another column that has the day and link together. When I merge this using the hyperlink function, it no longer takes the link with it and will only give me the date. This is a sheet that used to work (can't remember which build sorry) but now it doesn't. It just gives me the number and does not take the hyperlink. I will recreate the current problem and upload test files later today if that's okay?

Screenshot 2023-11-14 151854.png

Link to comment
Share on other sites

1 hour ago, Hangman said:

Thanks for the clarification... I've just been testing this in 2.3.0.2114 on macOS and I'm not seeing any issues but I may well be missing some of the specific details in terms of how your Publisher and/or excel file is set up... if you are able to upload even a simple sample where this is happening that would be really helpful...

I'm working on it! Doing a lot of "multi-tasking" today! 🙂

Link to comment
Share on other sites

So this is kind of janky but it should show the issue. The screenshot shows that they hyperlink says "Google". If I click on that in Excel it opens the link (and it used to work in Publisher). Now, when I insert the hyperlink Google it does not open or recognize it being a hyperlink. But, if I use the H-Link column, since it is just a web address, the hyperlink works.

 

To be clear, I was able to get it to function as I needed it to, but I was just surprised that I couldn't do it as before which meant I had to change all of the data in my excel file. It takes me to the year 2035 so it took some work!

Screenshot 2023-11-14 172726.png

Screenshot 2023-11-14 170225.png

Link to comment
Share on other sites

On 11/13/2023 at 3:58 PM, TPG said:

I am using the latest Beta (2.3.0.2114) and I have lost the ability to create a merge field with my hyperlinks. It worked in previous versions but now it keeps telling me that it cannot open the PDF viewer when it is supposed to open an external link. Is anyone else having this problem?

It's quite difficult to assess what is actually happening from your screen recording because we can't see your entire screen. We would need to know exactly how the URL in the Google column is constructed to get a better understanding of the issue though having said that, Publisher just reads that column as 'Google' and subsequently launches it as a URL of https://google.

I'm also, at this stage, slightly unsure of the need for the Google column, as in, why the need to use the text 'Google' in that column to apply the URL to if concatenating though maybe you have a good reason to do so. You mentioned this was working for you in an earlier version but I'm not seeing any difference in behaviour between v2.2.1 and the current v2.3.0.2114 Beta in this regard but I could equally be missing something...

If your intention is to create a calendar with clickable numbers that take you to the respective date in a Google Calendar then based on your Excel spreadsheet I would be inclined to create something more like the following (obviously including any additional columns required for the project). This simply takes the base URL for Google Calendar (Column F) and concatenates it in Column G using the relevant Date elements from Column A (which may be exactly what you are already doing with your Google column), so something like:

=HYPERLINK(CONCATENATE(F2,YEAR(A2),"/",MONTH(A2),"/",DAY(A2)))

Spreadsheet.thumb.png.a7d6115043ca76154dac5c83d6e9282a.png

I would then use the concatenated column as your Data Merge Hyperlink column in Publisher unless there is a specific reason not to... I have no idea why you're seeing the 'Failed to launch PDF viewer' message though... I think we would need to see a sample Publisher file exhibiting that particular issue to understand possible causes.

Publisher doesn't appear to read the underlying Link text applied to a word when using the data for Data Merge purposes, so I don't believe that approach is ever going to work, though I appreciate you mentioned that for you it was working in a previous version.

Affinity Designer 2.4.0.2301 | Affinity Photo 2.4.0.2301 | Affinity Publisher 2.4.0.2301
Affinity Designer 1.7.3 | Affinity Photo 1.7.3 | Affinity Publisher 1.10.8
MacBook Pro 16GB, macOS Monterey 12.6.8

Link to comment
Share on other sites

You guys are AWESOME and thank you for all of your input.

I have not been able to recreate what I did before that gave me the result I thought was gone. In light of that, it may, in fact, have been a PICNIC issue . . . 🫣

I believe I was able to use my named fields before discovering the Data Merge Tool (which I love and please don't ever get rid of it) but I used an older excel sheet and I think that is where I ran into problems.

So we can assume it was me that was the problem and not Publisher!

 

Thanks again!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.