Jump to content
You must now use your email address to sign in [click for more info] ×

[Not a bug] Colour Picker Tool does not automatically apply colour from one shape to another [iPad]


Recommended Posts

It looks like the color sampler well is being filled, but not the primary color well. It's acting like you were using the color sampler in the Color studio, rather than the Color Picker Tool. 

I see the same behavior.

You do not have Auto-Apply selected in the Context Toolbar. It is now located way over to the right, rather than on the left with the other Color Picker Tool options, and has defaulted to off:

 

image.png

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
PC:
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.3, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.3.1

Link to comment
Share on other sites

I think that having the Auto-Apply button where it is now, on the right, is probably a bug. But Serif will be able to say for sure.

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
PC:
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.3, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.3.1

Link to comment
Share on other sites

Yes, you are right, thank you. I’ve been re-installed both apps before testing but while the retail version has auto-apply button selected by default, the beta version does not (and its place has changed); hence the confusion.

Maybe a mod could erase this entry altogether — if there’s a bug it has nothing to do with this post.

StudioLink 256gb 11’ M1 iPad Pro

iPadOS 17 Public Beta 1

iPad Magic Keyboard

Link to comment
Share on other sites

26 minutes ago, rai44 said:

Maybe a mod could erase this entry altogether — if there’s a bug it has nothing to do with this post.

Probably best to leave it, both because the topic may result in a bug report (mine), and because this changed behavior is likely to surprise/confuse someone else, too, and they will find the answer here if they look :)

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
PC:
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.3, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.3.1

Link to comment
Share on other sites

  • Staff

It seems to be off by default which seems wrong to me. I'm not sure the position is wrong, though. Where would you expect it to be @walt.farrell? Hasn't it always been there since V2?

Actually, I'll concede on this one, I think it should be moved to the left. I'll get both logged.

Link to comment
Share on other sites

2 hours ago, Chris B said:

Hasn't it always been there since V2?

Nope. It was on the left, with the other Tool-specific options before this beta.

 

image.png

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
PC:
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.3, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.3.1

Link to comment
Share on other sites

  • 4 weeks later...
  • Staff

The issue "Colour Picker Tool: Auto-apply/Apply to Selection is now disabled by default" (REF: AFP-6303) has been fixed by the developers in internal build "2.2.0.1951".
This fix should soon be available as a customer beta and is planned for inclusion in the next customer release.
Customer beta builds are announced here and you can participate by following these instructions.
If you still experience this problem once you are using that build version (or later) please reply to this thread including @Serif Info Bot to notify us.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.