Jump to content

App very slow on Mac M1


Recommended Posts

Hello, 

I used the last version 19,1 on Mac M1 with 16 Go RAM. App use a lot of memory and CPU. I can't zoom or use tools like the pipette so much that lag. I try to uninstall and reinstall app but I have a same problem ....

Have you a issue or users have same problem ? Thanks a lit

Capture d’écran 2021-03-11 à 11.45.32.png

Link to comment
Share on other sites

  • Moderators

Hey titijennifer,

I am using an M1 MacBook Pro and it's blisteringly fast. Can you screenshot your Preferences > Performance dialog? I assume  you're using the latest version of Big Sur?

Is this specific to a document or can you get the  issue with a small JPEG when using  the tools  you mentioned?

Link to comment
Share on other sites

  • Moderators

If you reduce the RAM slider to say 14000 does this make a difference?

My M1 is only 8GB but all I have on it are the Affinity apps so there's nothing else to fight for resources. Can you humour me and also disable Metal and see if that makes a difference. 

Link to comment
Share on other sites

  • 9 months later...

Hello! I would like to add my humble experience. I'm using MacBook Air with M1 & 16 GB of ram and Big Sur 11.6.2. I also had lots of issues with overall performance until I switched from Metal acceleration to OpenGL. Affinity Photo still has performance hiccups, but at least eyedropper & selection tools are (mostly) performant. Most of the times I don't use apps heavy on CPU or GPU in parallel to AP, so IMHO it is not issue of lack of resources. I also have this performance issues while working on pixel art assets (128x128 max), so it is really strange. I also encountered some bugs in regard to mentioned tools but I will describe them in separate topic.

Cheers

Link to comment
Share on other sites

  • 3 weeks later...

I came here looking for a solution to my problem as I was having the EXACT same issues on my brand new M1 MacBook Pro which was making me wonder why I spent so much money on this computer.  Thankfully, as it turns out it was also solved (at least for now) by turning off Metal and using Open GL.  As this post goes all the way back to March 2021, I'm really shocked this hasn't been corrected nor addressed by Affinity.  

Link to comment
Share on other sites

  • 3 weeks later...
  • 1 month later...

I was also having severe issues with the spinning pinwheel/beachball popping up constantly. Disabling the Metal preferance seems to be the workaround for me as well.

I'm wondering what kind of potential performance we are giving up by doing this. Hopefully the developers are still working to solve the problem.

Affinity Photo 1.10.5, Mac OS 12.3.1, MacBook Pro M1 Max.

 

Metal disabled.png

Link to comment
Share on other sites

  • 2 months later...

Thanks so much for this information. It fixed the slow opening of Photo on my 16" M1, and the many beach balls whenever a tool was selected. Now it's almost instantaneous. Whew!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.