Jump to content

Screen flicker in Affinity Designer

Recommended Posts

For myself it helped changing one screen to 60hz and use affinity designer just there. But this should not be the deal as i use my two screens with AMD Eyefinity for gaming on 144hz aswell. I don‘t want to change the refresh rate every time i use Affinity Designer, as i use Designer allot this is a disturbing issue. Please fix this 😉

Best regards


Link to comment
Share on other sites

  • 3 weeks later...

I also have the flickering issue.

1440p 144hz monitor using the latest Nvidia drivers.

Apparently, Unreal Engine is also affected (several people in their Discord have acknowledged it).

I hope Nvidia are aware of this, but there has been two driver releases with this problem in now already.

Link to comment
Share on other sites

I have used following keys for solving my issue. I guess it is restarting the graphics driver. This is what i read. I don‘t need to switch between 144hz and 60hz anymore. If you want to try it on your own use this , the screen will turn black for a moment so don‘t be schocked or get in panic 😉  Ctrl+ Shift+ Win+ pressed B

Edited by HumAnCK
Link to comment
Share on other sites

Please note, I'm not a heavy user of the Affinity software, so this is for personal use rather than professional but not sure if this will help anyone?...

I've literally today got the Dell Alienware 34" ultrawide screen (with Nvidia G-Sync) and used Designer today and noticed the flickering, and it brought me here when searching the issue.

I was on the Nvidia drivers 471.41, and tried everything turning the refresh down to 60Hz however this didn't help and various settings on the monitor itself and Nvidia Control Panel, to no avail.

What I have found though I've just updated to 471.68 because I just noticed it needed updating to these latest drivers and so far so good - also this is at 120Hz (and tried with 60Hz also) and G-Sync turned on.  I'm now able to flick from one tool to another and move the mouse onto the document area without the flickering which was very noticeable and distracting!  Also this worked straight away without even having to close Designer.

Hope this helps?  I know, things like this aren't always helpful to everyone else as peoples setups for a Windows machine can be so different with so many different combinations of hardware.


Screenshot 2021-08-19 235910.png

Link to comment
Share on other sites

  • 9 months later...

Are you using the Studio Driver or the Game-Ready driver?  I use the Studio Driver and haven't had the issue and the refresh rates are at 144 (main display) and 75 (2nd and 3rd displays)

2022-05-20 11_34_21-GeForce Experience.png



Link to comment
Share on other sites

  • 2 weeks later...

None of the solutions that have been proposed so far really solve the issue. I would really prefer not to have to either:

  • Switch the refresh rate on my screen to 60Hz
  • Turn off G-sync on my screen
  • Switch between Game Ready Driver and Studio Driver whenever I want to work in an Affinity application

For completeness' sake, I'm using a Samsung 27" G7 Odyssey (LC27G75TQSNXZA) screen on an Nvidia RTX 3070.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.