Jump to content
postmadesign

Tool Shortcuts don't always save

Recommended Posts

I have an issue both with the App Store version and the Beta version of Designer with the tools shortcuts. I have tried to change some of these to make it more similar to other software, like making the pixel tool N and the fill tool F. But each time I quit Designer and restart the app, these changes are gone again. I had this issue with the app store version for a longer time already, but not with Photo, only Designer. I hoped that the Beta version would resolve this issue, but it seems the same thing happens here. I tried resetting some preferences, but it does not seem to change much. I saved the shortcuts and can reload them each time of course, but this is not ideal. Do you have any idea where this issue comes from and how i might be resolved?

 

Another related issue which also reported on in the app store version and now in the beta as well, is when I change tool shortcuts in preferences, I can add shortcuts for functions in the vector persona while I am in the pixel persona menu. This seems to be a bigger issue and might have something to with tools shortcuts not saving correctly.

Schermafbeelding 2020-08-02 om 09.43.53.png

Share this post


Link to post
Share on other sites

Hi postmadesigns,

This is something you've reported to us back in March. There are actually three separate issues here, that are still open with development:

  • Incorrect Tools for the selected persona are appearing in the Keyboard Shortcut list
  • Setting a keyboard shortcut for the 'Pie Tool' creates a duplicate entry in shortcut list
  • Keyboard shortcut for Pixel Brush Tool doesn't save after a restart

I've just tried the last one again as you mentioned and still only found that the Pixel Brush wasn't being saved - the Fill Tool was.

Share this post


Link to post
Share on other sites

Yes, indeed this is the same issue, but I reported it here too, because I thought it might have been some kind of corruption on the preferences in the App Store version, which would mean the Beta version might not be affected. But this does not seem to be the case, so the issue is somehow in Designer itself. I hope a solution can be found for this issue, as it is these kind of annoyances can really disturb the workflow.

Perhaps the last issue you mention might have something to do with the personas are somehow confused in the shortcuts, and as the N shortcut is already used in the Vector persona, this might cause it not to save?

I will do some testing to see if avoiding these double shortcuts might cure the issue.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.