Jump to content
Pluscuamperfecto

Flickering backlight on affinity photo background.

Recommended Posts

Hi. Something strange happens to me with affinity photo, which doesn't happen to me in any other artistic program, or not. The problem is that the background, flickers or changes color, becoming a little darker or lighter with certain actions (it is possible that even the canvas does, but where it really shows is in the background), I would say that what does is darken for half a second and then regain normal lighting.It happens in two ways. The first is done randomly when I press the alt, control, or shift modifier keys. The other, always happens in the same way, and it is curious because it does so depending on the tool you have selected. It occurs in two cases when it does. The first, when you move the cursor from the canvas to the background or from the background to the canvas. This only happens with the following selected tools: brush tool, mix brush tool, rubber tool, overexposure brush, all blur tools, except the finger tool. The second case occurs when you go from the background to the toolbar but not when you go to the canvas. This occurs with the following tools. Gradient tool, pen tool, geometric shapes tool and text tool. The color variation is not much, I did not notice it on my external monitor, until I changed the configuration to one with high light (presentation on my Benq monitor), but with this configuration it is very remarkable. I also could not make a video for a curious reason. As soon as I open OBS studio (my recording program), this flickering stops happening. I don't even have to record, just by opening the program this problem stops happening. In this designer forum they talk about something that seems similar

. I have verified that changing to WARP as it is said there the problem stops happening, but unfortunately the brushes become unusable due to their slowness, since Intel UHD 620 is the option that my card should use. My computer. HP Notebook, 16g ram, I7, Intel UHD 620 integrated graphics card. I use windows 10. Hope this problem can be solved. Thank you very much for your attention and greetings.

Share this post


Link to post
Share on other sites

Hey Pluscuamperfecto,

I assume you've done all the usual checks such as latest drivers and Windows updates etc. etc.

I'm puzzled as to why the screen recording software stops the flickering though. 

I'm trying to ask around the team to see if anyone has seen this before (other than what was presented in the linked thread). 

Share this post


Link to post
Share on other sites

HI. Yes, the updates are fine. The recording program thing is weird, yes. But it is not the only time I see it interact strangely with affinity. In another post about windows ink, where you answered me too, (thank you very much) I commented on it. The preview circle was frozen in the video after being recorded. I comment this in case it helps something. It seems that obs studio and affinity do not match well.About the g_sync, there is nothing n-vidia I think. Only the integrated Intel UHD 620 card. Mi laptop  is a  "HP Notebook - 15-dw0015ns". My laptop screen is very bad. There, I did not appreciate it. I noticed the problem when connecting it to my work monitor. Which I think doesn't have g-sync either. It is a Benq BL2420PT Monitor 23.8 "2K QHD 100% sRGB / Rec. 709 IPS screen, and as I comment when it is most noticeable is in the brightest modes.

Share this post


Link to post
Share on other sites

Hello again. I have some new information in case you are interested. I have recorded a video with the mobile phone, because I cannot do it with the computer. I've noticed that flickering, with the canvas-background tools, only flickers when a pixel layer is on. When the tool is toolbar-background, it always happens. In the video it is less noticeable than on the monitor, because the quality of the recording of the mobile phone is poor, but on the monitor it is much more noticeable. These are the steps I perform in the video: I use a Tool that gives problems when moving the toolbar_background (text tool in this case). Flickering occurs. Use Tool that gives problems in moving canvas_background (brush tool in this case), but without pixel layer. Flicker does not occur. I paint, and the assistant creates a new layer. Flickering occurs. I close the pixel layer, and repeat this last step. After, with one pixel layer , i Active OBS Studio, no flickering occurs. I close Obs Studio, flickering occurs (obs studio, prevents flickering with the two types of tools, those of the toolbar and those of the canvas, not only on the canvas tools, I forgot to record it). I hope it can be useful for you. Thank you very much for your attention and greetings. 

flikering_affinity.zip

Share this post


Link to post
Share on other sites

Thanks for the video. I can definitely see what you're referring to.

That monitor looks like it (ironically) has anti-flicker technology built into it. Could you have a look at its settings and let me know if it has that feature and if it is enabled/disabled and try the opposite setting.

Can you also see what refresh rate the monitor is running at? If you go to Display settings > Advanced display settings it should tell you.

Share this post


Link to post
Share on other sites
385/5000
 
 
 
Hi Chris, the refresh rate was 59 hz but I changed it to 60 hz and it happens exactly the same. The monitor does say that it is flicker free, and when trying to record it with the camera it seems that it is this way (doesn't flikcker on the record). But I have been looking in the manual and in the monitor options, and I have not seen that there is an option to disable it, so I guess it can only be enabled. Thanks Chris again for your attention. Greetings.

Share this post


Link to post
Share on other sites

Maybe this technology is unrelated to the issue. 

Possibly try updating your graphics drivers etc. if you haven't already. 

Have a look in the Windows Colour Management area too and see what profile you have set. 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.