Jump to content
You must now use your email address to sign in [click for more info] ×

Affinity Photo 1.7.3 for Windows Freezing on Export

Recommended Posts

I have a file that I am having trouble exporting. I have already successfully exported the image once but decided it needed a little more work. I added a High Pass and a description and tried to export. Ten minutes later AP was still trying to export. In going into the task manager, the CPU is working overtime (image attached). I have tried several other files from the same group of images I am working with. Every time I try to export my laptop sounds like it is prepping to leave the atmosphere as the fans turn on. Again, the task manager is saying the CPU is working overtime. I have attached the working file and my computer specs. If anyone can assist I would greatly appreciate it!


Computer Info.txt

Is there a place to pull a log I can send?


Screenshot (1).png

Link to comment
Share on other sites

  • Staff

Hi Matt4179,

Welcome to the forums :)

Please could you tell me what format you exporting the image to and the settings you are using? Crash logs can be found at: %appdata% > Affinity > Photo > 1.0 > Crash reports.


Please tag me using @ in your reply so I can be sure to respond ASAP.

Link to comment
Share on other sites

Hi Callum, thanks for the response! The format for export is JPEG @100%. I edit in ROM RGB colorspace and have it converted to sRGB for my website. I checked the crash report folder and there are a few in there from other crashes I have da over the last month, but since this event was not a crash, there was no report.

Incidentally, in ensuring I knew what I was exporting at, I ran the export again but let it export into the same folder I have all my working files in. It exported without issue, but when I tried to run it again in my original folder it would not export. I have checked the properties of the folder and everything looks fine. I don't know what in the world is going on. If we can fix it, awesome, if not at least I know there is a workaround.


I also tried opening AP in cmd to see if it showed information as the app was running as apps do in Linux so I could tell you what it is saying. If there is anything else I can do on my end to help, please let me know.

Edited by Matt4179
Added something I forgot to say.
Link to comment
Share on other sites

FWIW, I don't think AP actually is freezing; it is just taking a very long time (& all the CPU resources AP can access) to merge all the adjustment & particularly live filter layers you have applied to the 23 MP pixel layer, before the actual export can occur/

Your PC is much more powerful than my iMac (specs below in my sig) but I see something similar if I try to export your file -- CPU use shoots up to about 395% according to the Mac Activity Monitor app (which means it is using essentially all of my i5's 4 cores). I gave up & canceled the export after 4-5 minutes. I also tried the Merge Visible option, with the same results (except that with no "Cancel" button I had to force quit the app).

 So then I tried merging down each of the live filter layers one at a time, beginning with the lowest one in the layer stack. On each merge, CPU use still maxed out but took 'only' a little over 1 minute for each merge to complete. That left me with 9 adjustment layers & the one background pixel layer. After that, I tried the Merge Visible option again. Once again CPU use maxed out & the progress bar appeared stuck but after less than 2 minutes the process completed & CPU use dropped back to idle.

Exporting just this merged layer took only a short time & CPU use never exceeded about 25%. If you want, you can download my Waldnaabtal + merged layer.afphoto file (447 MB) & see if exporting just the "Merged (Select & export this layer only)" layer works for you, or just repeat the one-at-a-time merge down process with your original file to see how that compares on your PC to what I get on my iMac.

All 3 1.10.8, & all 3 V23.0 Mac apps; 2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.10.8; Affinity Designer 1.108; & all 3 V2 apps for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 15.7

Link to comment
Share on other sites

@Old Bruce I recently swapped to PC after 3 years with a Mac and have been kicking myself ever since. My Macbook's "specs" were way less than this MSI I'm running now and it was still faster. Though you could fry an egg on the bottom when editing video. Lesson learned. This will be my last PC. Thank you for running it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.