Jump to content
You must now use your email address to sign in [click for more info] ×

Search the Community

Showing results for tags 'hang'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Affinity Support
    • News and Information
    • Frequently Asked Questions
    • Affinity Support & Questions
    • Feedback & Suggestions
  • Learn and Share
    • Tutorials (Serif and Customer Created Tutorials)
    • Share your work
    • Resources
  • Bug Reporting
    • V2 Bugs found on macOS
    • V2 Bugs found on Windows
    • V2 Bugs found on iPad
    • Reports of Bugs in Affinity Version 1 applications
  • Beta Software Forums
    • 2.4 New Features and Improvements
    • Other New Bugs and Issues in the Betas
    • Beta Software Program Members Area
    • [ARCHIVE] Reports from earlier Affinity betas

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Website URL


Location


Interests


Member Title

Found 20 results

  1. This happened very reliably using v1 on my old 2012 MacBook, but I recently bought an M2 Mac Mini (16gb RAM) and was sad to see it still happens in v1.10.6 and the v2.1.1 trial under the latest Mac OS 13.5. I'm using an Intuos tablet. To recreate: Create a new document. Select pencil and set Controller to "Pressure" Sketch away Sometimes it only takes a couple of dozen strokes, sometimes a few hundred. It doesn't happen as reliably in v2, so maybe something did change between the versions. I haven't seen the hang triggered when: Controller is set to "None" Controller is set to "Pressure", but strokes are made with a non-pressure-sensitive mouse So, it seems it's only triggered when variable-width strokes are being drawn to the screen. I tried setting Controller to "Automatic" and was able to get a hang in v1, but I haven't seen one in v2 yet (but this could just be v2's overall improvement in reliability). I've tried using Metal instead of OpenGL rendering in both versions and haven't seen any difference in frequency. I only tried software rendering once in v2 and it hung after a few dozen strokes. I can post the OS-generated reports if needed (I've already sent dozens to Apple). Using all versions and renderers, the tail end of the "heavy stack" looks something like this: 65 Affinity::LegacyDocumentViewController::MouseUp(Kernel::Counted<Tool>, Kernel::PointT<float> const&, ToolPointView const&, unsigned int) + 400 (liblibaffinity.dylib + 1813136) [0x10c686a90] 65 Tool::MouseUp(ToolPointView const&, unsigned int) + 968 (liblibpersona.dylib + 14148792) [0x12cb3e4b8] 65 HandleTool::OnEndDrag(ToolPointSpread const&) + 388 (liblibpersona.dylib + 38360520) [0x12e2555c8] 54 PencilTool::PencilHandle::OnEndDrag(HandleTool&, ToolPointSpread const&) + 2612 (liblibpersona.dylib + 90372016) [0x1313ef7b0] 44 Geometry::CurveDbl::ExpandAdaptive(Geometry::PolygonType<double>&, double, Kernel::RectT<double> const*, bool*, bool) const + 1268 (liblibgeometry.dylib + 1275440) [0x1068c7630] 17 Geometry::CurveSegmentCubicBezier::Expand(Geometry::PolygonType<double>&, double, Kernel::RectT<double> const*, bool*, int) const + 400 (liblibgeometry.dylib + 1086264) [0x106899338] 4 Geometry::CurveSegmentCubicBezier::IsLinear(double, Kernel::RectT<double> const*, bool*) const + 228 (liblibgeometry.dylib + 1129112) [0x1068a3a98]
  2. I installed Publisher V2 on my new MacBook Air 15', and forgot to install the Swedish hyphenation file I Library/Spelling. When I tried to open a fairly complicated Book project (3 Chapters) with a lot of long sidenotes originally started on my main Mac Studio, all went well until I tried to open the third Chapter, which resulted in a perpetual "Opening the file", with a resulting depletion of System App memory and a forced shutdown. The Chapter file would also not open individually, likewise for all the previously backed-up versions of the same file. Installing the hyphenation file solved the problem, the file is opening fine now. In the file, the only difference to the other Chapter files are a few veeery long sidenotes, which before I minimised the font size for those particular sidenotes, pushed subsequent sidenotes too far forward over the spreads, so that a lot of white space was introduced. (BTW - a big Thanks for the Sidenotes feature. I suppose ID still lacks those)
  3. Steps to reproduce: Create a new document Create 3 text objects Lock one of them Deselect all objects Shift select one unlocked text object, then the other, all is well and as expected Without letting go of Shift, try to select the locked text object The app will hang, Affinity Design will start using a lot of CPU time See video below for a visual guide. Workaround for this bug is... waiting. The app will eventually unfreeze itself, but it might take a while. On a Ryzen 3700x it takes around 3 minutes to become responsive again. EDIT: The first time you trigger this bug, the app will take the longest to regain responsiveness again. On subsequent triggers the app will still become unresponsive, but recover much faster... 🤔 Thanks! Gravação 2023-07-13 122658.mp4
  4. Having trouble saving or closing files or returning to the Affinity Gallery, I’ve discovered the following: This usually occurs after a shared asset or drive is shut down After exactly 1 minute the app may start responding Saves maybe almost immediate but app hangs for 1 minute after the save If the connection to the shared drive is killed from the iPad file manager after loosing the connection, the app seems to behave normally. See image below, when share is turned off at source, iPad maintains share like its still there. It appears the app times out after 1 min, but when I tried to open a .afphoto file from file manager it waited 1 minute then after that it displayed the message “Downloading” wait another minute then the file opened. The file was local and should open immediately. Closing the connection not so easy, I start to open new connection (but cancelled), after that it killed the old one. When still connected can kill connection by clicking on blue icon but doesnt work (maybe I didnt wait for a programatic time out).
  5. It seems to me that if while using the iPad AP, the internet connection is lost or a shared drive becomes unavailable, iPad file management seems to hang. If working on a file in AP when this happens, can no longer save even if file is local on My iPad, wheel just spins forever.
  6. I am running version 1.10.1 of Publisher on a Windows surface book 3. When I go to the "My Account" to download addons I can successfully download an addon but after the green tick mark appears when I click on the close button the application hangs (window and task manager show "not responding". After waiting 10-20 minutes I had to force the app to close. I have tried other addons and each appears to do the same thing. I have been successful in downloading the same addon in Affinity Designer (1..10.1) and all was fine there. Is anyone else having this issue? Is there a fix/workaround? Cheers, Jamie
  7. My affinity photo hangs and does not recover while making curves adjustment. I was following the steps mentioned in following tutorial to adjust skin tones. https://affinityrevolution.com/color-correct-skin-affinity-photo-tutorial/ While adjusting the red channel affinity photo hangs. CPU usage during hang. Even after waiting for 5 minutes affinity photo doesn't recover. Affinity Photo Version: 1.9.2.1035 Windows Version : Windows 10 - OS Build 19042.867 I am trying to create a repro for this issue, by that time can any one confirm of there are any known issues with version? Thanks.
  8. I am using the latest MacOS (Big Sur 11.2.3) and the latest Affinity apps and had a crash after which I am no longer able to startup any Affinity app. They hang and also make the Mac finder hang! I have never needed to reboot my Mac so often... I have tried deleting all caches etc and reinstalling the apps downloaded from my account... without succes I have cleared everything after using Ctrl on startup of publisher and now the app window appears, but then also hangs... and so does the Finder again... I am out of ideas and I need affinity publisher urgently for my business, thanks for any help, Sven
  9. Hi, I found (by accident) a new way to kill Publisher. We verified that this "works" on both W10 and latest Mac OS on 1.9.1 both. There are no ways that i know to fix this, which is hugely annoying. A simple file like this: https://www.dropbox.com/s/3h24qf2syswxn5r/v5 - Copy.afpub?dl=0 You just need to open it and it will freeze the Publisher. It worked a long while, but resizing one VP star (out of quite many that the file has) that had by itself bloated (which is annoying feature that just happens - some symbols will be randomly resized when you copy the page or part of it they are on). I tried to set the star to 6x6 mm. And Published demanded that it HAS TO BE 7,6x6 mm (bloated size was 55x6 mm) and then, after saving, this is the result. The mac user is totally pissed as now Publisher tries to open that file no matter how you open Publisher. So, essentially he has now Publisher that can't do anything. On Windows you can at least open another file, but with Mac you can't. I believe he will need to reinstall whole Publisher. This is quite crucial bug. And I'd very much appreciate if this is resolved quickly.
  10. Hi Affinity revolution people. I'm in love with all three producst on Windows, but there has been a huge problem for me for the last couple of versions. Totally suddenly, my Windows 10 (Version 1903 x64 KB4497165) stops reacting to all keystrokes, the mouse moves for approx 10 seconds, then freezes as well. This happens in Publisher only, no other application has ever behaved like this. I just have to perform a hard system reboot by pressing power button for 5 seconds, nothing else helps. I remember having the 1.7.2 for a long time and then jumping to 1.8.2 and 1.8.3 and the latest one I've spent a lot of time with is 1.8.3.641. All of them did this to me at some point. Regardless of the file I was working on, sometimes after a few seconds after starting up, sometimes after 2 hours of work. Thank God for the autosave. Previously I was accusing my Duet app, which is listed in the Windows troublemakers, but even without it installed the problem persists. My Lenovo ThinkPad Yoga P40 has both a dedicated GPU and an Intel integrated GPU, maybe the problems might stem from here. I'm not sure. Here's my System Information: OS Name Microsoft Windows 10 Pro Version 10.0.18362 Build 18362 Other OS Description Not Available OS Manufacturer Microsoft Corporation System Name THINKPAD-P40-YO System Manufacturer LENOVO System Model 20GQ001SMX System Type x64-based PC System SKU LENOVO_MT_20GQ_BU_Think_FM_ThinkPad P40 Yoga Processor Intel(R) Core(TM) i7-6500U CPU @ 2.50GHz, 2592 Mhz, 2 Core(s), 4 Logical Processor(s) BIOS Version/Date LENOVO R05ET81W (1.59), 2019-05-14 SMBIOS Version 2.8 Embedded Controller Version 1.25 BIOS Mode UEFI BaseBoard Manufacturer LENOVO BaseBoard Product 20GQ001SMX BaseBoard Version SDK0J40697 WIN Platform Role Mobile Secure Boot State On PCR7 Configuration Elevation Required to View Windows Directory C:\Windows System Directory C:\Windows\system32 Boot Device \Device\HarddiskVolume2 Locale Czechia Hardware Abstraction Layer Version = "10.0.18362.752" User Name THINKPAD-P40-YO\Simon Time Zone Central Europe Daylight Time Installed Physical Memory (RAM) 16.0 GB Total Physical Memory 15.9 GB Available Physical Memory 8.13 GB Total Virtual Memory 21.6 GB Available Virtual Memory 11.9 GB Page File Space 5.75 GB Page File C:\pagefile.sys Kernel DMA Protection Off Virtualization-based security Not enabled Device Encryption Support Elevation Required to View Hyper-V - VM Monitor Mode Extensions Yes Hyper-V - Second Level Address Translation Extensions Yes Hyper-V - Virtualization Enabled in Firmware No Hyper-V - Data Execution Protection Yes And the Display folder from the System Info: Name Intel(R) HD Graphics 520 PNP Device ID PCI\VEN_8086&DEV_1916&SUBSYS_505A17AA&REV_07\3&11583659&0&10 Adapter Type Intel(R) HD Graphics Family, Intel Corporation compatible Adapter Description Intel(R) HD Graphics 520 Adapter RAM 1.00 GB (1,073,741,824 bytes) Installed Drivers C:\Windows\System32\DriverStore\FileRepository\igdlh64.inf_amd64_273cd687c73e4b9b\igdumdim64.dll,C:\Windows\System32\DriverStore\FileRepository\igdlh64.inf_amd64_273cd687c73e4b9b\igd10iumd64.dll,C:\Windows\System32\DriverStore\FileRepository\igdlh64.inf_amd64_273cd687c73e4b9b\igd10iumd64.dll,C:\Windows\System32\DriverStore\FileRepository\igdlh64.inf_amd64_273cd687c73e4b9b\igd12umd64.dll Driver Version 26.20.100.6998 INF File oem51.inf (iSKLD_w10_DS section) Color Planes Not Available Color Table Entries 4294967296 Resolution 1920 x 1080 x 59 hertz Bits/Pixel 32 Memory Address 0xD0000000-0xD0FFFFFF Memory Address 0xC0000000-0xCFFFFFFF I/O Port 0x0000FF80-0x0000FFBF IRQ Channel IRQ 4294967287 Driver C:\WINDOWS\SYSTEM32\DRIVERSTORE\FILEREPOSITORY\IGDLH64.INF_AMD64_273CD687C73E4B9B\IGDKMD64.SYS (26.20.100.6998, 19.12 MB (20,047,464 bytes), 2019-07-17 01:59) Name NVIDIA Quadro M500M PNP Device ID PCI\VEN_10DE&DEV_137A&SUBSYS_505A17AA&REV_A2\4&91A2562&0&00E8 Adapter Type Quadro M500M, NVIDIA compatible Adapter Description NVIDIA Quadro M500M Adapter RAM (2,147,483,648) bytes Installed Drivers C:\Windows\System32\DriverStore\FileRepository\nvltwi.inf_amd64_9090484f46d8b338\nvldumdx.dll,C:\Windows\System32\DriverStore\FileRepository\nvltwi.inf_amd64_9090484f46d8b338\nvldumdx.dll,C:\Windows\System32\DriverStore\FileRepository\nvltwi.inf_amd64_9090484f46d8b338\nvldumdx.dll,C:\Windows\System32\DriverStore\FileRepository\nvltwi.inf_amd64_9090484f46d8b338\nvldumdx.dll Driver Version 26.21.14.4250 INF File oem24.inf (Section046 section) Color Planes Not Available Color Table Entries Not Available Resolution Not Available Bits/Pixel Not Available Memory Address 0xD1000000-0xD1FFFFFF Memory Address 0xA0000000-0xAFFFFFFF Memory Address 0xB0000000-0xB1FFFFFF IRQ Channel IRQ 4294967289 Driver C:\WINDOWS\SYSTEM32\DRIVERSTORE\FILEREPOSITORY\NVLTWI.INF_AMD64_9090484F46D8B338\NVLDDMKM.SYS (26.21.14.4250, 22.21 MB (23,286,504 bytes), 2020-03-07 11:18) Can you please help me with this? I've been experiencing this for a very long time now and finally I have the time to tackle this issue. Previously, I just had to finish stuff and just had to "brute force" through it... :( Šimon
  11. I was experimenting with batch converting arw to jpg on about 10 files with different parameters (with or without "convert to sRGB macro, pixel format default, rgb, cmyk, embedded sRGB profile). Anyway, I decided to output around 118 images that I'd already successfully output with sRGB macro/embedded profile, and I think rgb pixel format (maybe left at default). Importing in the same dir where I recently deleted a 10-file batch. parallel checked. The batch job spun up and got to "saving" on the first 24 images but never made it past that. CPU hung out high for about how long it would take to save them then went to idle but the gui still says "saving". I was writing to a NVMe SSD. The drive is not full. under task manager Affinity photo beta is using 29GB (I have 256GB) and barely any (less than 1/2%) of CPU (712 threads). There's another process - crashpad_handler.exe at 0% cpu (6 threads). Been this way for maybe 20 minutes now as I waited, then started writing this. Nothing in event logs. From looking at the thread handles in Resource Monitor it looks like maybe it's trying to write crash info. I attached a txt file with the copy/paste of the handles from Affinity Photo and Crash Handler. System Info: Win 10 Pro 1909 build 18363.836, 256 GB RAM, 2x EVGA RTX 2080 Super GPU, AMD Ryzen Threadripper 3960X 24-Core (SMT off), ASRock TRX40 Creator mobo Affinity_beta_CPU_Handle_Dump.txt ---EDIT--- As a followup, I can't even reproduce what I did to successfully output images in batch. I can do little batches now, but haven't been able to reproduce the 118 image batch - I keep hanging. Have tried all sorts of color profiles and combos of clicking JPG/macro options. have also tried DNG/ARW. Haven't reset my pc yet but that's next. Also tried to do batch in non-beta and had the same hang. --EDIT-- rebooted and still cannot find settings that successfully generate a 118 image batch (except turning off parallel processing). The first one I did worked in parallel (accidentally left box checked to generate affinity format photos and had to delete them) but I tried that too and it didn't work. -EDIT- I did some more tests and things work fine with parallel processing up to 20 images, break at 22. When it breaks the CPUs stop running sooner than when it works (with message saving jpeg... and spinning wheel). I have no idea why I was able to make it work for a whole run my first time, but I wish I could repeat that luck. I know I included the sRGB macro, which I don't need, and I know I ran it from the developer persona, and I know I accidentally created the affinity-format files too, and I was working on a sRGB workflow, but I've tried all the permutations of that my patience can handle, and I haven't been able to find that magic that makes me get the whole batch done with all 24 cores. Which means I'm stuck with one. Unless I can set processor affinity to 20.. maybe I can do that.. And in case you're wondering I regularly peg out all my cores (and GPU cores) on other things, so I don't have some hidden system instability. incidentally it would be nice if the batch settings (output dir/source dir/output type checkboxes/file type options) were persistent instead of resetting to default every time. And I'd love a ctrl-shortcut for batch or at least an alt-F-something shortcut. let me know if I can help debug. also a CLI for batch like darktable-cli would be super-amazing. I'd buy you a case of beer for that Oh how I miss having beers with friends...
  12. Windows 10 Home 1903, Designer 1.7.2.471. Steps to reproduce: * Open Designer; * Create new document; * Switch to Export persona; * Application hangs. I don’t think many people would want to do this in practice but I don’t think they should be penalised for doing so.
  13. Application Hang macOS - Designer Computer: iMac Retina 4K, 21.5, 2017, Radeon Pro 560 4 GB macOS: 10.14.6 (all updates) Designer: 1.7.2 Used the Duplicate command to copy a simple rectangular shape. After using Command J four (4) times I used Command S to save the recent changes. The application hung with a spinning beach ball and had to force quit to recover. Report attached: Affinity Designer _2019-09-09-204251_iMac.hang.zip
  14. Steps to reproduce Create a mask Right-click on the mask and select Refine Mask... Screenshot Version Affinity Photo 1.7.1.404 OS Windows 10 Home (64 bit) | Version 1809
  15. I use Affinity Photo 1.7.0 for Mac OS and the view tool is constantly hanging. By that I mean that once I use the view tool, I cannot switch to any other tool no matter what. I have to save and close my file and then open it again to get out of the view tool. This happens at random intervals, but is guaranteed to happen every time I use AF. I find this to be a major productivity obstacle. The previous version did this too sometimes, but the upgrade has made it much worse. Is anyone else experiencing this?
  16. I tried to import a .docx file and it locks up every time.
  17. I've already reported this same bug in Publisher 1.7.0.273 which I've also discovered effects Designer 1.7.0.8 and has not been detailed as fixed in the latest beta 1.7.0.9 so figured maybe it's not yet been reported? The bug: like publisher, I've tried opening existing documents and noticed hangs of around two minutes when click drag to position anything on a page but I've nailed it down to having complex vectors in a document, once the culprit vector is removed /switched off in the layers panel, Designer then comes back to life and works at normal speed - the culprit vector detailed here was created in designer and has shown no problem in previous betas as I've used it on 3 previous jobs and caused no slowdown, I've also ran a few tests and noticed this on other documents which I new contained relatively complex vectors which previously showed no problems, I've notices that theres no slowdown when moving or resizing the culprit logo, just other items on a page, also nudging and shift nudging using arrow keys works normally, same with changes using the transform panel all resizing and positioning works as normal, the hangs seem to be caused by curser movement resizing and positioning I'm currently holding back to Photo 1.7.0.112 as it works normally with these files and complex logos - Also the assets panel is working normally in Photo 1.7.0.112 but is broken in Publisher 1.7.0.273 and Designer 1.7.0.8 Find attached 'Hanging vector test.afdesign' Hanging vector test.afdesign
  18. Affinity Beta Photo hang in separate modality. I saved spin dump if it need.
  19. Mouse slipped while dragging the Crop tool which resulted in a teeny tiny area to crop in a large image. Got the spinning beach ball. Tried to back out with Cmd/Z. No effect. Gave it a minute or two then tried Quit. No Effect. Tried Force Quit. The Force Quit window said it was gone and the dock icon lost its open indicator. However, I still had the Affinity Menu Bar, the full workspace and the spinning beach ball with no way to get rid of either of them. Can't Force Quit something the Finder no longer sees. I wound up having to Shut Down my machine to get out of it. It doesn't seem like a situation that would likely occur often, maybe never again, and I didn't lose anything because of it but it seemed like it might be worth reporting. OS: Mountain Lion Photo Beta: 25787
  20. Using Affinity 1.1.2 on Mac, system 10.7.5, when I export a document as EPS then go to the desktop, then come back to my document it has frozen, nothing is active and the spinning beach ball of death appears! Only force quit rectifies this! It happens every time, any ideas? Update - Just found the solution, downloaded the Beta version and it's fixed.
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.