Jump to content
Smee Again

Text On Path (Windows 10, Designer 1.7.2) includes video of problem

Recommended Posts

I use the program for mapping a lot. That means that I have to place text on path in order to align with streets correctly.

Last time I commented on this, I was having trouble with the program allowing me to add the text on the path because the cursor would never place the tilde "~" next to the arrow so that I could attach the text to the path. Solved that problem by angling the path, adding the text then adapting the path to the part of the map where it belongs. Slow, but worked.

Sometimes the text does not align to the beginning of the path, so while still in text editing mode, I grab the green triangle and slide it to the left end of the path. Problem fixed.

Not anymore with version 1.7.2. Now, if you grab the green triangle to drag it to the beginning of the path, the program pulls the orange triangle which controls the break where the text goes below the path right up against the green triangle forcing all of the text after the first letter to the bottom of the path . . . upside down.

If I try to move the orange triangle to the right to correct the problem, even though I pull the orange triangle, only the green one moves. This means that I now have to delete the text and path (undo doesn't work for some reason while doing this) and start over.

Here is a video of what I'm talking about:

I'm beginning to think that where the cursor shows it is clicking is not where it is actually clicking --- you'll notice at the beginning of the video where the click happens vs where the points actually show up.

Share this post


Link to post
Share on other sites

I'm having the same problem.  Thought you'd like to know you're not alone.  In my case I'm taking pretty random kind of parallel lines - elevation lines - and placing text on them so I don't really have the option of moving the line, placing text and moving the line back.  Can be done but not easily.  Move the green triangle and everything goes to the left including the orange.  Run the green to the right to the end and then reverse the text usually does the trick.  Sometimes that puts the text on the wrong side of the line and then I have to start over (in my case undo works) and place the text on the other side of the line somewhere and do it all again.  Crazy slow but it gets me there.  I adjust the triangles prior to typing any text so the dark triangles are not present with reversed text. 

 Just noticed that my mouse is buggy - probably one of the buttons is not closing correctly - so that may be my problem.  Perhaps your mouse has issues?

Just tried it in AD 1.7.1.404 and there is not problem - so the new version introduced the bug.

Share this post


Link to post
Share on other sites

Hi Guys,
I've just reproduced this and will pass it on to development. In the meantime you should be able to temporarily move the green node out of the way (after the initial 'snap' to the wrong position), move the other nodes accordingly before moving the green back into position. If that is not the case would you be able to attach the file you're editing please?

Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.