Jump to content
gionaguidi

Psd file compatibility: not showing correctly

Recommended Posts

Hi guys, 

 

i tried opening a complex Photoshop file which basically is a resume organized in 4 pages with multiple layers each. The file is definitely big (300mb) but the problem seems to have to do with compatibility between the file created in Photoshop and how AP will manage the same objects. In particular, there’s a smart object in PS which is a photo that should be visible only as a portion covered by shapes in other layers. Unfortunately the photo is not visible at all unless i re-organize the layers but obviously that brings to losing the original order of layers and the picture is totally visible instead of being shown as a portion only. In PS everything is working perfectly. 

E39AD40E-CC3A-4247-96FA-70E1DC1D1386.jpeg

3CDAD0EE-9358-46E1-8099-87BF1297F601.jpeg

7B24FC25-1416-4CED-A4DD-160E1DE50E0B.jpeg

Share this post


Link to post
Share on other sites
16 minutes ago, MEB said:

Hi gionaguidi,
Welcome to Affinity Forums :)
Currently Affinity apps don't support Photoshop's smart objects. They are rasterised on import.

Hi MEB, 

 

thanks for welcoming me here. I understand... so this is a big problem when it comes to switch from PS to AP because all of your previous files that have smart objects won’t work properly. Any known roadmap on adding smart objects in AP?

Share this post


Link to post
Share on other sites
1 hour ago, MEB said:

Hi gionaguidi,
As far as i know we do intend support smart objects but there's no eta for its implementation. It's not in the Affinity Photo's roadmap for the 1.x cycle of the app (although we occasionally implement some things not listed/planned there).

Ok thanks for your feedback anyway. I want to highlight that besides the limitations with smart object the app for iPad is constantly crashing with this psd file. I lowered the time between each auto saving but the app is crashing so frequently that every single adjustment on the file is not saved. 

Not that easy to rely on this piece of software for people coming from PS and its proven stability honestly. 

Share this post


Link to post
Share on other sites

Hi again,

 

any chance to get support on my constant crashing? May i email someone at Affinity Support a download link to the psd file so they can investigate what is causing the app to be totally unusable working on it? THANKS 

Share this post


Link to post
Share on other sites

Does it also happen if you save the file as native affinity file, instead of keeping it as a *.psd ?  I would perhaps try that. Even saving it so, close it, and open the new native file to work on it the rest of the time. With the possibility of at the end export again as a PSD, if you absolutely need the final in that format (probably would need to flatten or rasterize some things for the very final PSD save, but the result could be made 1:1, visually). I don't know if has to do with that, I'd just try that.  And is only pure instinct, I have no other reason.


Affinity Designer and Affinity Photo licenses, Windows 7, i7  860 (2009) 2.8 GHz,  8 GB RAM, GTX 1050 2 GB, HD 7200 RPM.  Wacom Intuos 4 XL.

Share this post


Link to post
Share on other sites

If you post on the 'IPad Bugs' thread you will usually get a response from moderators.


IPad Pro 10.5 512GB iOS 12.1 Affinity Photo 1.6.11.85 Affinity Design 1.6.4.45

Share this post


Link to post
Share on other sites
14 hours ago, SrPx said:

Does it also happen if you save the file as native affinity file, instead of keeping it as a *.psd ?  I would perhaps try that. Even saving it so, close it, and open the new native file to work on it the rest of the time. With the possibility of at the end export again as a PSD, if you absolutely need the final in that format (probably would need to flatten or rasterize some things for the very final PSD save, but the result could be made 1:1, visually). I don't know if has to do with that, I'd just try that.  And is only pure instinct, I have no other reason.

Will definitely give this a try and keep ypu posted on the result. Thanks

Share this post


Link to post
Share on other sites
10 hours ago, DM1 said:

If you post on the 'IPad Bugs' thread you will usually get a response from moderators.

Thanks for the information i thought this was the correct thread. I will immediately write there for another problem

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×