Jump to content

Recommended Posts

Hi,

I have an issue with my wacom tablet (Intous 5)

It seem to not work at all, both in Photo and Designer. Not only the pen pressure (even though the wacom tablet settings menu show that pressure is working) but the display toggle for multiple screens feature isn't working as well.

The issue is only with affinity. I use ZBrush all the time and tablet works just fine. Windows navigation works too (display toggle feature).

I can't recall if it was like this before wacom did driver update - I didn't use Photo too often and I just purchased Designer.

But I had no issues in anything else.



So I'm asking for some help with that ;)

Thanks.

 

Share this post


Link to post
Share on other sites

In Designer you must be in Pixel persona and then choose what you want to be affected by pressure by selecting the More button on the Context Toolbar. Choose the Dynamics tab. In Photo it is the same except you are already using pixels.


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.4

Affinity Designer 1.6.1 | Affinity Photo 1.6.7 | Affinity Publisher beta 1.7.0.293 | Affinity Photo beta 1.7.0.120 | Affinity Designer Beta 1.7.0.9

Share this post


Link to post
Share on other sites

So the pressure aint work with vector brush? Even if there is pressure set for the brush,  like size and opacity variance?

 

Share this post


Link to post
Share on other sites

Pressure does work for vector brushes. Try looking in the context toolbar and see if pressure is selected for the controller. 

pen_pressure.thumb.JPG.87c6484f4c24c3863f193f700b7c3785.JPG


AMD A12-9700P Radeon R7

10 Compute Cores 4C + 6G

12 GB Ram,  AMD R7 Graphics

Share this post


Link to post
Share on other sites

I have a XP, but maybe the same "traps"? 

The GLOBAL pressure button on/off just works if the pressure-slider of the current brush is set to zero. THAN it will take the pressure on/off-button (yes/no)  (with the envelope behind) ... otherwise the pressure from the current brush will taken, dosent matter if this button is on/off! (and it works only for pressure = size; other pressure-settings will not on/ff by this button). Vector-brushes has a "inside-pressure by brush-design" no really "manually pressure". Next is juts for pixel-brushes!

SERIF uses a "mouse-off-trigger" for most UI-elemts (layer/brush/swatch....)  (For me its very nasty, there is no advantage, but its app-concept...) For example: A "click" in a layer or swatch, brush... will not activate this item... first the "release-click" will activate! With a pen/tablet you allways have to "lift-up/out-bring" your pen a little bit from the tablet. Its confusing and a doubleclick with this "technique" is really hard to perform.... 

Maybe the pressure-envelopes are not the best in Serif-Brushes. Serif prefers "extrapolation" envelopes, but this need a lot of pressure to get to 50%. I prefer the opposite - logarithm   or linear curves... but its on you. You can also invert the curve... the stroke become fatter with lesser pressure... BUT YOU HAVE THIS TO SET FOR EACH brush seperatly... there is no "take this settings temporailly / or batch them all..." Its a prison-work, to personalize your brushes, there is no way to better view your brushes, no way to rightclick.... and so on. The free Krita is 1000 better for painting... 

However, my xp-pen works really well. I have to restart/unplug after each update... but after this... no problems/issues/miss.... Just 1time after maybe 6 weeks... there was a "hangout", but could fix "on the fly" after unplug/replug it. Except this, NO issues, i´m happy with that that tool... It needs neraly zero CPU, get sleep if the pen outside the tablet.... and "awakes instant"....

 

Maybe unplug the tablet/restart computer, cable-in and first than start AP! (i have to do after all updates).


OSX 10.13.5  / iMac Retina 27" / AMD Radeon R9 M380 / Metall: on!

Share this post


Link to post
Share on other sites

Thank you both.

So I must have issue with my tablet for both apps - Photo and Designer and only for them.

Besides the pressure issue, every time I use 2 monitors, the affinity aps just messes the pointer - jumping almost randomly from time to time.

The tablet and drivers must be alright because I use it with other pas like ZBrush or Krita or just as a pointer instead of mouse. Only Affinity aps work wrong.

I guess I will wait till 1.7 comes up with my complaining and messaging the support team ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×