Jump to content

Recommended Posts



Not sure If my system is borked but I seem to be having troubles copying text from an Affinity Designer Text Frame into another plain text editor.


Simple command-c to command-v does not seem to cut it, nor does working from the edit menu.


Any tips?





Link to comment
Share on other sites

Hi marsofearth,

Can you give us a few more details?

Was the text in the text frame pasted from another source or was created/written in Affinity Designer/Photo?

Which plain text editor are you trying to copy the text to?


Sorry I'll try to be more clear.


Using Affinity Designer, I used the Frame Text Tool to create a text frame.

I then typed text into the text frame.

I then wanted to copy that text into another application.

I tried Apple Notes, Text Edit, Pages, Microsoft Word, even Google Docs.


Since there is no contextual right/click menu when selecting the text from within the Text Frame, I tried Command-C then Command-V,

Then tried the copy from the Edit menu.


Thats my story and I am sticking to it!



Link to comment
Share on other sites

  • Staff

Hi marsofearth,

Thanks for the info. I'm having trouble reproducing this. I can copy the text to both TextEdit and Pages, selecting both the text frame or the text inside the frame itself.

Are you running any utilities that may interfere with those commands (copy/paste) like clipboard managers/shortcut/automation or similar menu apps?

If so can you try to disable them and try copy/paste the text again please?

Link to comment
Share on other sites

Hmm interesting,


I closed the Affinity Designer Document and re-opened it, and now I do have a contextual menu on right-click now.


Also I notice that on paste into text edit the text is getting pasted but at 0.5 pt perhaps this is why I did not see it?


select all and command + fixes this, 


Just some strange behaviour I am not used to.


About utilities,  I do have 1 password manager, google drive and creative cloud, but no other utilities that I can think of that would intercept the clip board.


It is odd that the contextual menu was not working before, I assure you I know how to right-click :)



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.