Jump to content
You must now use your email address to sign in [click for more info] ×

APh 2.1 - not respecting right click on pen when in Windows Ink mode

Recommended Posts

APh 2.1

Win 10 22H2

Pen display Huion Kamvas (I tried two models: Kamvas Pro 20, Kamvas 24 4K)

When the pen input method is set to Windows Ink in APh, then the right click setting of the pen is not working.

When set to either low or high precision then right click is working.

I have cross checked with Windows desktop and Krita: in both the right click is working with Windows Ink.


Link to comment
Share on other sites

  • 3 weeks later...
  • Staff

I've tested with a Huion Inspitoy Q11K, Right click works fine on this particular tablet.

My driver options do not have the "use mouse events etc...." option, have you tried disabling this?


Link to comment
Share on other sites

18 hours ago, Lee_T said:

My driver options do not have the "use mouse events etc

It is not a driver setting, it is in the painting software called Krita. It seems they identified, there needs to be some cool API trick to get right click working in Windows Ink mode.

The Inspitoy is a graphics tablet not a pen display - maybe there is a difference in the driver architecture.

I tried a bunch of other software (ClipStudio Paint, Krita, Rebelle, Davinci Resolve, XNView, ...) - right click is working everywhere except Affinity.

Maybe something to be looked into in the future - in end it is not a big issue. Affinity right click works in wintab mode which is good enough in most cases. Windows Ink is just better for me at resolving pen tilt and very light brush strokes. But that is subtle and I need it only for detailed painting, which I continue to do in dedicated software anyway.

Link to comment
Share on other sites

Hello everyone.
I can confirm the problem as cgidesign described it.
This problem is not new, it was also reported in version 1 as far as I can remember.

I use a Huion Inspiroy 1060P.
In all other programs, such as Krita, Photoshop, etc., the pen works perfectly.
There is another problem with the high precision.
Draw a line with the brush, undo this line with CTRL,
one point remains visible. (where the brush was applied)



Affinity Photo 2.3.0:         Affinity Photo 1.10.6: 

Affinity Designer 2.3.0:    Affinity Designer 1.10.6:

Affinity Publisher 2.3.0:   Affinity Publisher 1.10.6:    

Windows 11 Pro  (Version 23H2 Build 22631.2715)


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.