Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Photo: Issues and/or bugs with shortcuts for changing brush size


Recommended Posts

I use Affinity Photo 2.0.3 on Windows 10 with a german keyboard layout.

Summary: There are at least two three issues/bugs with shortcuts for decreasing/increasing brush size:

  1. Default Shortcuts "[" and "]" don't work on a german keybord under Windows (as already observed by Gonzo64 in this post).
  2. Shortcuts "ä" and "ö" delete the whole layer/mask one is working on when pressed twice
  3. Numbers as shortcuts only wotk on the numeric keypad

Detailed descroption:

The default keys "[" and "]" for changing brush size dont't work (and are by the way not comfortable to type on a german keyboard: "AltGr"+"[" and "AltGr"+"]"). I haven't changed anything in the sortcut settings so far.

So I tried the keys "ö" for decreasing and "ä" for increasing.

This works, but when I press "ö" or "ä" twice the whole layer or mask I'm working on gets deleted! Not only the content of the layer/mask but the layer/mask at all!

Next thing I tried, was assigning "8" and "9", but his works only with the numeric keyboard, although when defining I pressed "8" and "9" on the non-numeric keyboard. But I would like to press shortcuts with my left hand while moving the mouse with my right hand).

Edited by max1josef
The issue with ä and ö was caused by another app (forgotten autokey macro). Sorry for that.
Link to comment
Share on other sites

2 hours ago, max1josef said:

The default keys "[" and "]" for changing brush size dont't work (and are by the way not comfortable to type on a german keyboard: "AltGr"+"[" and "AltGr"+"]"). I haven't changed anything in the sortcut settings so far.

I can confirm that. If I remember correctly, I or someone else reported this a looong time ago.

2 hours ago, max1josef said:

This works, but when I press "ö" or "ä" twice the whole layer or mask I'm working on gets deleted! Not only the content of the layer/mask but the layer/mask at all!

It seems to work as expected for me. Does this happen with all kinds of layers and masks?

Link to comment
Share on other sites

Posted (edited)
On 12/31/2022 at 3:11 PM, Michail said:

It seems to work as expected for me. Does this happen with all kinds of layers and masks?

I tried it with pixel layers and layer masks.

For the time being I use "A" for increase and "<" for decrease. These shortcuts are not assigned to anything else by default and easy to type.

Nevertheless it would be fine, if Serif looked over this issues. At least the non-working "["/"]"-Keys are reported by several users, namely Gonzo64, you and me (and the poster you remembered from a while ago).

Edited by max1josef
typo
Link to comment
Share on other sites

5 hours ago, Michail said:

Perhaps another app on your computer uses a key combination that includes "ö" or "ä".

You are right! I have assigned autokey macros to replace "ää" with "&auml;" and so on. The macros start with backspace ...  I have long forgotten about these macros in times of unicode. Sorry for the confusion 😳

Link to comment
Share on other sites

  • 4 weeks later...
  • Moderators

Hi @max1josef,

Thanks for your report and our sincerest apologies for the delayed response here. We are exceptionally busy following the release of V2 and we thank you for your continued patience and understanding here.

On 12/31/2022 at 11:04 AM, max1josef said:

Default Shortcuts "[" and "]" don't work on a german keybord under Windows (as already observed by Gonzo64 in this post).

As confirmed by my colleague in the referenced thread above, and by myself here -

On 1/23/2023 at 11:51 AM, Dan C said:

I can confirm that the keyboard shortcuts in Affinity aren't keyboard layout 'aware', meaning they unfortunately don't automatically change when changing your input language.

For this reason, you will need to change the shortcut keys for your keyboard language currently, though this is logged as an improvement with our development team for automatic language detection and alternate shortcut presets to be considered in a future update.

On 12/31/2022 at 11:04 AM, max1josef said:

Numbers as shortcuts only wotk on the numeric keypad

I can confirm this is expected behaviour, as the 0-9 numerical keys along the top of the keyboard are set to the Opacity Quick Keys shortcut, as described here:
https://affinity.help/photo2/English.lproj/index.html?page=pages/Layers/layerOpacity.html?title=Layer opacity

Quote

To use opacity quick keys:

  1. Select a single layer or multiple layers.
  2. Press a numerical key, or two numerical keys in quick succession, to set the opacity. For example:
    • Press 4 for 40% opacity.
    • Press 0 for 100% opacity.
    • Press 4 and 5 for 45% opacity.
    • Press 0 and 7 for 7% opacity.

These shortcuts can't be disabled or changed, therefore any custom shortcut you set will need to use the numpad - else you are invoking the opacity shortcut.

I hope this clears things up!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.