Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Clicking text layer in Layers Panel no longer escapes cursor from text


Recommended Posts

In the V1 apps, if the cursor is active in a text object, clicking the text layer in the Layers Panel escapes the cursor... resulting in the text layer being selected with no active cursor, so I can to use a keyboard shortcut (i.e., using a shortcut doesn't type anything into the selected text).

In V2, clicking a text layer does not escape the cursor from the text object.

I often use the ESC key to escape the cursor, but depending on where I'm at in my workflow, it's convenient to have the option to click the text layer. I'm assuming this is a bug because I don't know why it would have changed in V2.

There are several posts about an issue selecting text. The issue I'm reporting seems unrelated, but I mention it in case the code is somehow related.

 

Link to comment
Share on other sites

3 hours ago, Brian_J said:

In the V1 apps, if the cursor is active in a text object, clicking the text layer in the Layers Panel escapes the cursor... resulting in the text layer being selected with no active cursor, so I can to use a keyboard shortcut (i.e., using a shortcut doesn't type anything into the selected text).

In V2, clicking a text layer does not escape the cursor from the text object.

FWIW it still works the same way in v2 Mac so this is a Windows-specific issue.

Affinity Publisher/Designer/Photo 2 for macOS Ventura 13.2, MacBook Pro 14" (M1 Pro)

Link to comment
Share on other sites

  • 2 weeks later...
  • Moderators

Hi Brian_J

This still seems to be working fine for me here on Windows if I hit the small Text box icon to the lefthand side of the layer in the layers panel is this not the case for you?

Thanks
C

Screenshot 2022-12-05 at 13.40.02.png

Please tag me using @ in your reply so I can be sure to respond ASAP.

Link to comment
Share on other sites

9 hours ago, Callum said:

This still seems to be working fine for me here on Windows if I hit the small Text box icon to the lefthand side of the layer in the layers panel is this not the case for you?

Ah okay, yes that works for me. In V1 clicking the layer thumbnail escapes the cursor, I didn't realize the location moved to the layer icon. Thanks for your help.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.