Jump to content

UNSHARP MASK is not being applied!!!!


Recommended Posts

Hi,  I am running a MacBook Pro using the latest "Catalina Version 10.15.7" and when I am applying the "Unsharp Mask" to sharpen an image, the image goes sharp WHILE THE MASK IS BEING APPLIED, "however" once the mask is finished "BEING APPLIED" it "does not apply to the image, it stays being unsharpened!!!!!

 

Can anyone advise please????

Link to comment
Share on other sites

Hi, @ChrisA380

Is the layer u will apply a image layer or a pixel layer? If it is a image layer you have to rasterize before, to take effect to the unsharp mask.

AMD Ryzen 5 5600G | 32 GB DDR4 3200MHz | Sapphire RX 5600 XT 6 GB | Windows 11 Pro (22H2 Build 22621.436)
Affinity Suite V1.10.5.1342
Better translations with: https://www.deepl.com/translator  
SVG preview in Windows Explorer with "SVG-See  Download SVG-See

Those who want to achieve something are looking for solutions,
the others always see only the problem.

Link to comment
Share on other sites

2 hours ago, Komatös said:

If it is a image layer you have to rasterize before, to take effect to the unsharp mask.

In AP on my Mac, if in the Assistant options for Applying filters to vector layers, I have Rasterize layer and apply filter enabled, even though that just mentions vector layers, then the image layer is automatically rasterized when I apply the Unsharp Mask to it & click the Apply button.

If that option is not enabled, then I cannot even select that or any other filter from the Filters menu (aside from Colors > Multiply by Alpha or Colors > Divide by Alpha).

But if I can apply the filter, whether it is a pixel or rasterized vector or image layer, it always is applied when I click the Apply button. So I wonder if the OP is not clicking the Apply button & maybe just closing the filter window or something.

Affinity Photo 1.10.5, Affinity Designer 1.10.5, Affinity Publisher 1.10.5;  2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.10.5.280 & Affinity Designer 1.10.5 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 15.0.2

Link to comment
Share on other sites

@R C-R

You are right, but If the layer ist a image layer, there is no automatism that rasterize the layer to an pixel layer. Or in the german version this function is missing. 🤔

AMD Ryzen 5 5600G | 32 GB DDR4 3200MHz | Sapphire RX 5600 XT 6 GB | Windows 11 Pro (22H2 Build 22621.436)
Affinity Suite V1.10.5.1342
Better translations with: https://www.deepl.com/translator  
SVG preview in Windows Explorer with "SVG-See  Download SVG-See

Those who want to achieve something are looking for solutions,
the others always see only the problem.

Link to comment
Share on other sites

1 hour ago, Komatös said:

@R C-R

You are right, but If the layer ist a image layer, there is no automatism that rasterize the layer to an pixel layer. Or in the german version this function is missing. 🤔

In the Mac versions, as I said, if in the Assistant options for Applying filters to vector layers, I have Rasterize layer and apply filter enabled (& of course if the Assistant itself is enabled) then then the image layer is automatically rasterized when I apply any filter to it.

Assistant.jpg.89cf6e76f03397528f396ca69df2f1aa.jpg

Does this not work in the Windows version?

Affinity Photo 1.10.5, Affinity Designer 1.10.5, Affinity Publisher 1.10.5;  2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.10.5.280 & Affinity Designer 1.10.5 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 15.0.2

Link to comment
Share on other sites

6 hours ago, Komatös said:

You are right, but If the layer ist a image layer, there is no automatism that rasterize the layer to an pixel layer. Or in the german version this function is missing. 🤔

What do you mean by "German version" – this is a language setting only for the displayed text in the UI.
However, Affinity is aware about my German macOS language (which causes the known preflight dictionary-missing issue) – but the Assistant does the auto-rasterization:

92151423_assistantrasterized.jpg.d9817cfc83d83e401fd328a4da6a2513.jpg

... which can be nasty if you Undo the action which triggered the Assistant but forget to do a second Undo for the rasterization. Then you may loose image resolution and also nested non-destructive, editable items (e.g. adjustments, live filters) and might not notice it in time.

macOS 10.14.6, MacBookPro Retina 15" + Eizo 27"

Link to comment
Share on other sites

@thomaso  @R C-R

OK, my fault. I haven't tried before anwwering. So it works as expected, without the need to rasterize first.

AMD Ryzen 5 5600G | 32 GB DDR4 3200MHz | Sapphire RX 5600 XT 6 GB | Windows 11 Pro (22H2 Build 22621.436)
Affinity Suite V1.10.5.1342
Better translations with: https://www.deepl.com/translator  
SVG preview in Windows Explorer with "SVG-See  Download SVG-See

Those who want to achieve something are looking for solutions,
the others always see only the problem.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.