Jump to content
You must now use your email address to sign in [click for more info] ×

Unpredictable Behaviour on Affinity Versions

Recommended Posts


I have been an affinity user for a number of years, I have Publisher, Photo, Designer.

I am seeing really unpredictable behaviour with the latest versions of these tools. Tonight I wanted to use the clone brush. I pasted in an image. I made sure it was rasterised. I then held the Alt key and left clicked. The cross hairs briefly turned to a circle. I then tried to paint (as I have done a 100 times before) The History register "Clone Brush Tool", but a message appeared. "You must Alt Click to set a source before trying to clone". I tried numerous times. I made sure nothing was selected. I duplicated the layer and tried on the duplicated layer. Nothing worked. 

I selected the image and copied it into a new affinity photo file. Same behaviour. No clone.

I closed down the program, opened it up again. This time everything worked. I have been hitting this issue repeatedly since the most recent update. A feature just stops working for a period of time, then by creating a new file or restarting the program it works again.


Link to comment
Share on other sites

Hi, @DrakeSoftand welcome to the forums.

Make sure you have selected one of the options "Current Layer & Below" or "Layer Beneath" if you want to clone from one layer to the other.


AMD Ryzen 7 5700X | INTEL Arc A770 LE 16 GB  | 32 GB DDR4 3200MHz | Windows 11 Pro (22621.2283)
Affinity Suite V 2.2.0 & Beta
Better translations with: https://www.deepl.com/translator  
Need a system wide color picker? Try Microsoft's (New) Power Toys

When life offers you only lemons, make limoncello out of them.

Link to comment
Share on other sites

There was only a sigle layer in the image. I have seen equally erratice behaviour with the selection tool. Sometimes it is impossible to select a section and paste it to a new layer. One ends up with an empty layer, or a copmplete copy of the source layer. Affinity provides no visual feedback as to what is happening. I have not seen this behaviour in previous versions of the product.

Link to comment
Share on other sites

Hi DrakeSoft!

To copy a selected area to a separate layer, the layer you copy from needs to be rasterized. Don't know if it was in your case, but some time ago I came across this problem. So possibly it is the same to you now.

Anyway, this eratic behaviour of the cloning in fact sounds like a technical issue to me too. I can't replicate it. I'm on Windows 10 with all apps in version Are you on Windows or Mac?

I remember that I had a somehow similar problem years ago, that was caused by a malfunction of a key on my keyboard. Can you exclude this by trying another keyboard (if you have one)? Or check out if other functions using the Alt-key also cause problems.

Link to comment
Share on other sites

THank you for your reply. Yes I always rasterize, but it would be nice if Affinity gave a meaningful message when you try and work on a non-rasterised image with an incompatible function. 

In this case it was a single layer.

I did also suspect the keyboard or mouse so I switched to a wired mouse and the problem persisted. I can see the cursor transition as well when I click and select the Alt key and I can see the function invoked and written to the history window. It just refuses to clone telling me I have not set a source as shown in the image above.

The next time it happens I will try and take a video of it.

Link to comment
Share on other sites

2 hours ago, DrakeSoft said:

Yes I always rasterize, but it would be nice if Affinity gave a meaningful message when you try and work on a non-rasterised image with an incompatible function. 

If you mean what is marked with an "(Image)" suffix in the Layers panel, then copy isn't exactly an incompatible function because even though it will copy the entire layer instead of just a 'marching ants' selection, there are use cases for that, like to make a copy to paste into the current or some other document as an image layer, without restricting it to the selection.

In fact, a 'marching ants' selection is a separate entity, not attached to or a part of any layer in the document. It only has any meaning or function when used in combination with a pixel layer, one with the "(Pixel)" suffix.

A bit weird or non-intuitive but that is just the way it works.🤷‍♂️

All 3 1.10.6, & all 3 V21.1 Mac apps; 2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.10.6; Affinity Designer 1.10.6; & all 3 V2 apps for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 15.7

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.