Jump to content

Bug in Color Picker


Recommended Posts

I found a bug in Color Picker, here is some record about that problem. I had the same problem with 1.10.5 and 1.10.4 versions. It also happens when I use digital pen or mouse click.

EDIT: Take a look at 0:04 time on the video. When I click in the blue side (where the subtitle appears), the color windows doesn't change to blue.

Link to comment
Share on other sites

Sorry, but it's very difficult to tell from that video what you're doing. Please explain in words exactly what you were doing and what you think should have happened.

(Feel free to use your native language, rather than English, if you prefer.)

-- Walt

   Desktop: new:  Windows 11 Home, version 21H2 (22000.613) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090  (old: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970 )
   Laptop:  Windows 10 Home, version 21H2 (19044.1706) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
    Affinity Photo 1.10.5 (.1342) and 1.10.5.1342 Beta   / Affinity Designer 1.10.5 (.1342) and 1.10.5.1342 Beta  / Affinity Publisher 1.10.5 (.1342) and 1.10.5.1282 Beta
 iPad Pro M1, 12.9", iPadOS 15.6.1, Apple Pencil 2, Magic Keyboard

  Affinity Photo 1.10.5 (.280) and 1.10.2 (.266) Beta / Affinity Designer 1.10.5 (.21) and 1.10.3 (.19) Beta 

Link to comment
Share on other sites

18 minutes ago, walt.farrell said:

Sorry, but it's very difficult to tell from that video what you're doing. Please explain in words exactly what you were doing and what you think should have happened.

(Feel free to use your native language, rather than English, if you prefer.)

Hello.

Take a look at 0:04 time on the video. When I click in the blue side (where the subtitle appears), the color windows doesn't change to blue.
Thank you.

Link to comment
Share on other sites

  • Moderators

Hi @Halex,

I've attempted to replicate your issue however this has worked as expected on my side, could you send me a screenshot of your performance settings in Edit > Preferences > Performance?

Also, if you were to continue to click back and forth between the blue and white side with the colour picker, would it start to work again?

Link to comment
Share on other sites

1 hour ago, Halex said:

When I click in the blue side (where the subtitle appears), the color windows doesn't change to blue.

Thanks. But what are you clicking with?

Is this with the Brush Tool with Alt Pressed? You haven't said, in this topic. And just saying Color Picker would normally mean the Color Picker Tool.

-- Walt

   Desktop: new:  Windows 11 Home, version 21H2 (22000.613) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090  (old: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970 )
   Laptop:  Windows 10 Home, version 21H2 (19044.1706) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
    Affinity Photo 1.10.5 (.1342) and 1.10.5.1342 Beta   / Affinity Designer 1.10.5 (.1342) and 1.10.5.1342 Beta  / Affinity Publisher 1.10.5 (.1342) and 1.10.5.1282 Beta
 iPad Pro M1, 12.9", iPadOS 15.6.1, Apple Pencil 2, Magic Keyboard

  Affinity Photo 1.10.5 (.280) and 1.10.2 (.266) Beta / Affinity Designer 1.10.5 (.21) and 1.10.3 (.19) Beta 

Link to comment
Share on other sites

1 hour ago, NathanC said:

Hi @Halex,

I've attempted to replicate your issue however this has worked as expected on my side, could you send me a screenshot of your performance settings in Edit > Preferences > Performance?

Also, if you were to continue to click back and forth between the blue and white side with the colour picker, would it start to work again?

Hi

Here is the print of my Performance. Yes, It works if I continue clicking, but sometimes it happens again. Thank you.

Print.png

Link to comment
Share on other sites

34 minutes ago, walt.farrell said:

Thanks. But what are you clicking with?

Is this with the Brush Tool with Alt Pressed? You haven't said, in this topic. And just saying Color Picker would normally mean the Color Picker Tool.

In this video I'm using Alt + Click, but I've already tryied with Color Picker Tool and I had the same problem.
Thanks.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.