Jump to content
You must now use your email address to sign in [click for more info] ×

Recommended Posts

I am having an issue that I need help resolving.

I was under the impression that the best way to share a file with another Affinity Publisher user, was to save the file as a package. 

That is what I have done. And the other person has Affinity Publisher, same version as I do (1.10.4), also on a Mac.. When they go to open the file on their Mac, they get the error "Cannot open package file "(filename here).afpackage." Access to packaged resources was denied."

What is going on? And how do we overcome it?


Thank you,


Link to comment
Share on other sites

3 minutes ago, Robby Poole said:

I was under the impression that the best way to share a file with another Affinity Publisher user, was to save the file as a package.

I assume you do mean an Affinity Publisher package file here (so like told in this bad explanation here). - Well may depend on where they saved it (the path) and then tried to open it then from. - They might also wan't to check if it is compressed and can be uncompressed the right way.

 Further, if you often have to exchange Publisher things and get problems then with it's packaging method, you may better archive/package the stuff as a ZIP or TAR+GZ etc. via common macOS system or graphical third party tools.

☛ Affinity Designer 1.10.8 ◆ Affinity Photo 1.10.8 ◆ Affinity Publisher 1.10.8 ◆ OSX El Capitan
☛ Affinity V2.3 apps ◆ MacOS Sonoma 14.2 ◆ iPad OS 17.2

Link to comment
Share on other sites

You may have inadvertently set some restictive permissions on the folder you chose for saving the .package folder to.

Mac Pro (Late 2013) Mac OS 12.7.4 
Affinity Designer 2.4.1 | Affinity Photo 2.4.1 | Affinity Publisher 2.4.1 | Beta versions as they appear.

I have never mastered color management, period, so I cannot help with that.

Link to comment
Share on other sites

Here is how everything happened.

I saved the package file to an iCloud folder. I tried to share the folder. It had issues with the sharing. I had to share it again. Still nothing. Finally I moved the folder to an existing folder that the other person and I already have shared. Then he was able to access the folder. Copied to his desktop, and when he attempted to open the file, he got the error message.

I have since created a new package to the iCould folder that we already share. I will see if this makes a difference. But aside from that, I have not restricted access to anything pertaining to the package itself.



Link to comment
Share on other sites

OK, here is where I am at..... The packaged file is 316 MB, so e-mailing the whole thing is impossible.

I sent 3 versions of the book to the author to open on their computer:

1) A package file created on a folder on my desktop.

2) The same package file zipped up.

3) A trimmed down version of the book with over 180 pages deleted, and no graphic images, etc.


The author is still having issues opening #1 and #2 from above. He gets the error as described above. The picture shows the error message.

#3 the author could open the pages, and Publisher was asking to locate the missing resource files.


For the record.... In the Save as package dialogue box, I viewed all of the fonts, none of which are restricted, all showed green marks. I did the same for the images. All images were green, some were embedded, some were linked. All 1,000 + graphics were green, no errors detected.


I am really at my wits end here. Nothing is locked, nothing is set to restrictive permission as far as I can tell (please tell me where to look for this). I saved the original package folders directly to my iCloud Drive. The most recent test, I saved it to my hard drive, then copied to iCloud Drive. As well as taking the folder from my desktop and "compressing it" (ZIP file). And then copying the ZIP file to my iCloud Drive.


Thanks for the help! Anyone have any other suggestions?



Link to comment
Share on other sites

OK, I think part of the problem with the author's computer is that Publisher does not have permission to access certain folders.

Below is a screen shot of my system preferences, and his. 

Mine has the red circles, his does not.

He tells me when he opens the file it asks him for permission, which he says yes. Then he gets the error screen shown in the post above. 

Is this the problem, and if so, how does he add Publisher and the locations necessary?



Screen Shot 2021-12-05 at 11.40.53.png


Link to comment
Share on other sites

41 minutes ago, Robby Poole said:

However, now he sees the TIFF images as blurry objects. Is there a way to fix this?

That sounds like the linkage between the .afpub file and the Linked resources is broken. If he has them all in the proper directory/folder, perhaps just opening the Resource Manager and clicking on Relink would work.

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.5, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.5

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.