Jump to content

Adjustment layers in a folder


Glyphs
 Share

Recommended Posts

This happens in all three Affinity Apps on a mac: when I put adjustment layers into a folder, if I then try to export the file in PDF, the adjustment layers aren't recognized. I have to either put the adjustment layers outside of the folder for these layers to be recognized, or export a JPEG version. 

Link to comment
Share on other sites

2 hours ago, Dan C said:

Hi @Glyphs,

Thanks for your report!

Can you please provide a sample Affinity document and a screenshot showing your PDF export settings (including the 'More...' dialog) so I can look into this further for you?

Many thanks in advance :)

Here is a sample file. While creating it, I discovered another bug: put the Pixel Layer into the Adjustment Group Folder, and it will cancel the Adjustments.

Advanced Settings.png

Sample.afphoto

Link to comment
Share on other sites

32 minutes ago, Glyphs said:

While creating it, I discovered another bug: put the Pixel Layer into the Adjustment Group Folder, and it will cancel the Adjustments.

That is not a bug. By design, if a group contains adjustments and a pixel layer, the adjustments apply only to that layer. That's one purpose of grouping them. If you want them to apply to everything below them, either don't group them, or don't include the pixel layer in the group.

-- Walt

   Desktop: new:  Windows 11 Home, version 21H2 (22000.613) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090  (old: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970 )
   Laptop:  Windows 10 Home, version 21H2 (19044.1706) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
    Affinity Photo 1.10.5 (.1342) and 1.10.5.1342 Beta   / Affinity Designer 1.10.5 (.1342) and 1.10.5.1342 Beta  / Affinity Publisher 1.10.5 (.1342) and 1.10.5.1282 Beta
 iPad Pro M1, 12.9", iPadOS 15.6.1, Apple Pencil 2, Magic Keyboard

  Affinity Photo 1.10.5 (.280) and 1.10.2 (.266) Beta / Affinity Designer 1.10.5 (.21) and 1.10.3 (.19) Beta 

Link to comment
Share on other sites

1 minute ago, walt.farrell said:

That is not a bug. By design, if a group contains adjustments and a pixel layer, the adjustments apply only to that layer. That's one purpose of grouping them. If you want them to apply to everything below them, either don't group them, or don't include the pixel layer in the group.

Sorry, I kind of mixed things up while working on the file:) How about the PDF export?

Link to comment
Share on other sites

2 hours ago, Glyphs said:

How about the PDF export?

I can't explain what's happening with the PDF export from your uploaded .afphoto file. Sorry.

With luck Dan (or another Serif employee) will be able to figure it out.

-- Walt

   Desktop: new:  Windows 11 Home, version 21H2 (22000.613) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090  (old: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970 )
   Laptop:  Windows 10 Home, version 21H2 (19044.1706) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
    Affinity Photo 1.10.5 (.1342) and 1.10.5.1342 Beta   / Affinity Designer 1.10.5 (.1342) and 1.10.5.1342 Beta  / Affinity Publisher 1.10.5 (.1342) and 1.10.5.1282 Beta
 iPad Pro M1, 12.9", iPadOS 15.6.1, Apple Pencil 2, Magic Keyboard

  Affinity Photo 1.10.5 (.280) and 1.10.2 (.266) Beta / Affinity Designer 1.10.5 (.21) and 1.10.3 (.19) Beta 

Link to comment
Share on other sites

  • Moderators

Many thanks for the file provided!

I can confirm this is happening due to a bug with Grouped Adjustment layers that have Masks applied when exporting to PDF - I'll be sure to log this file with our development report regarding this now. In the meantime you can simply remove the group and the document will be exported correctly.

I hope this helps :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.