Jump to content

Failed to save document: Save failed because access to the file was lost.


Recommended Posts

I created a document yesterday on my D:\ saved everything throughout the evening with no complications then saved and closed it for the night. I re-opened the document today and created one page, then saved my progress as usual but this time I was prompted with an error which then closes the entire program and I lost the progress I've made. The file location hasn't changed overnight, it's housed on a secondary HDD of my (less than 3 month old) computer.

I tried to move the document to my external drive and work from there, but I get the same error message when saving. Please see the attached image for reference. I don't recall ever having this sort of issue with Affinity Publisher in the past and I'm very confused on what I should do and if I've lost all of my work.

I'm using version: 1.9.2.1035

Don't judge the file name, lol. I'm working on a project for my D&D Campaign.

 

SaveError.PNG

Edited by ajoiner87
added versioning for more information as well as tags.
Link to comment
Share on other sites

To get around this, I opened the file in Designer. Saved it as a Designer file, then re-opened it in Publisher... that seemed to work. This is a massive issue though and hopefully is being addressed for the next update. Or maybe add a pages view in Designer and an option (artboards aren't enough) then do away with Publisher all together! 

Link to comment
Share on other sites

In designer before attempting to save again, I converted all images to pixel layers instead of linked documents. I've verified through the resource manager that there are no documents open for this file.

image.png.b6dee05c27f25ef94dee01fab8b8c595.png

I tried to "Save As" and was prompted with a new error:

image.png.4d482c0f84cdf45ba0ca30ef062aac40.png

My hope was to be able to get it to work at least within Designer... I'm baffled and extremely annoyed at this point.

Link to comment
Share on other sites

1 hour ago, ajoiner87 said:

I tried to "Save As" and was prompted with a new error:

That sounds like you have too many files open. You might try closing some other applications, but my guess would be that the actual issue might be the number of fonts you have installed.

-- Walt

   Desktop: new:  Windows 11 Home, version 21H2 (22000.613) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090  (old: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970 )
   Laptop:  Windows 10 Home, version 21H2 (19044.1706) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
    Affinity Photo 1.10.5 (.1342) and 1.10.5.1342 Beta   / Affinity Designer 1.10.5 (.1342) and 1.10.5.1342 Beta  / Affinity Publisher 1.10.5 (.1342) and 1.10.5.1282 Beta
 iPad Pro M1, 12.9", iPadOS 15.6.1, Apple Pencil 2, Magic Keyboard

  Affinity Photo 1.10.5 (.280) and 1.10.2 (.266) Beta / Affinity Designer 1.10.5 (.21) and 1.10.3 (.19) Beta 

Link to comment
Share on other sites

 

1 hour ago, walt.farrell said:

my guess would be that the actual issue might be the number of fonts you have installed

I have 2 fonts installed outside of the standard fonts. I find it hard to believe that would be a contributing factor.

*note the file uses 2 typefaces, one being a Windows default font and the other custom.

To test the number of applications thought, I've closed all but Designer, browser window, and one other application and I'm getting the same error with Designer as I was with publisher about access to the file being lost.

What could be causing the application to lose access to a local file? This seems to be the most critical issue. The secondary error has been hit or miss in my testing today.

image.png.d5abd83703afcd196dce2feb0331c365.png

The fun part is, after taking the time to rasterizing all of the linked images to pixels to try to reduce the number of open documents with it... When saving I received the above error too. So all of the layer conversions were lost on 45 pages.

I've seen others with similar issues, but I've not seen anything regarding a resolution or consistent workaround.

Link to comment
Share on other sites

  • 7 months later...

Hello everyone,

the last entry was some time ago and I'm just wondering — is there a solution already? i have the exact same issue but in my case everything is working fine
as long as I don't use a cloud-service which synchronizes the data...

this is a bit of a problem because i need to share the data between different departments...

anyways - thanks for any hint/solution in advance :)

happy new year btw.

best regards
rob 

Link to comment
Share on other sites

  • 2 months later...

Hello,

i have almost half year same issues at publisher and designer...cannot save document:/// New version not help, uninstal not help, change windows from 10 to 11 not help....please, did have some one what can i do with this? Thank you...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.