Jump to content

App hangs on save panel --> force quit needed :/

Recommended Posts

Hi folks

This is now way to long (more than 1.5 year?) that I experience a bug when saving.
But recently, because of the great lack of features on actions (no copy, no document switching, etc. :(), I had to do a —lot— of manual manipulations and savings on many file, and I experienced the bug like 1x out of 3!
The only way then is to force quit the app and to start over. That's a great amount of frustration.

I'm on the Export Personna, when I click "export" for my slices, the save panel opens, and the app will hangs indefinitely (both happened on Designer and Photo, most probably on Publisher but I've not tried yet).
The hang is not instant, it can triggers after a couple of seconds or more rapidly.
I'm sorry guys, I don't know the responsible, but it's definitely there. I've seen a couple of posts here for such hangs, but users were using Windows, so I'm not sure.
My feeling is that it has to do with "what's" actually on the Finder, like, mounted SMB, iCloud, etc. Still not sure.
I'm 100% working with an SMB volume mounted (not the one I'm saving on and working though).
However, all my working files are saved on iCloud Drive (Desktop and Documents on iCloud option checked).

Thanks for the support.



Link to comment
Share on other sites

  • 1 month later...

Well, Affinity's Apps are the —only— one I'm using which can hang on save panel.
I'm using iCloud Drive for all my works. This is now system integrated.
It worth considering the apps could have a real bug that need to be fixed no?

(I decided to come and post on your answer because Affinity Photo just hang…)


Link to comment
Share on other sites

  • Moderators

The cloud service we found to actually cause issues on a regular basis was Google Drive—iCloud Drive from what I recall during testing was usually fine. Saying that, it was normally files becoming corrupt due to a loss of connection etc.

Does the hang occur when the dialog first opens or when you select the correct drive from the side?


Link to comment
Share on other sites

  • Moderators

That's interesting - I wonder if perhaps it's struggling to load/function if it's x amount of levels deep into a cloud structure. That's definitely something for us to go on. I imagine if your recent folder was always 'Desktop' it would not happen. 

That's helpful - thank you.

Link to comment
Share on other sites

This is the closest I have found to my own problem. If it's not the right place I apologise.

Over the past two weeks I have been unable to export anything from Affinity Photo. The app seizes up and I have to do a Force Quit. BTW I export all my photos to my desktop since I moved to Big Sur (on my new iMac).

I use AP daily and am finding this a real problem. I tried reinstalling AP and wonder if you have any suggestions for how I might remedy the situation.

Thank you,


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.