Jump to content
GeoQer

SVG files disorganized in other software

Recommended Posts

Hello,

I am new to the forum, but can't seem to find anyone else with this problem. I bought AD for creating content to etch with my laser engravers. One is an imported Galvo Fiber laser using EZCAD2. I have tried exporting several different supported files types out of AD, but the files either open empty or open scattered. The only way I have been able to work around this is by exporting to a pdf and using Zamzar conversion service to convert to an SVG.

I'm sure it is something goofy that EZCAD2 is being picky about. The only only file I have had export directly from a design software and into EZCAD2 was out of Adobe Illustrator, but only when saved as the Japanese .ai format.

Is there an export setting I can use to make this work properly directly from AD? I have attached example files from AD.

Thank you for your help.

tail-AD.jpg

tail-EZCAD2 import.jpg

tail.afdesign tail-AD.svg

Share this post


Link to post
Share on other sites

I exported your document to SVG and it looks fine in Inkscape (attached image) and Firefox.
I opened your SVG in Firefox, Edge, Chrome and Inkscape and that looks okay too.
I don’t know the software you are loading the SVG into but that seems to be the thing at fault here, as far as I can tell.

Screenshot 2020-11-04 083416.png

Share this post


Link to post
Share on other sites

Thank you for the response, but I know the files open in other design software and that my problem more an issue with EZCAD2 than with AD. The problem is I can get an SVG to import correctly when imported from Zamzar. To  me this means there is a setting that is not set to properly export from AD and import directly into EZCAD2. My question is for anyone who has encountered this issue before and if they figured out a way around it.

Perhaps a developer may know what the difference is between the files. I have attached the version I had converted from a PDF on Zamzar. Best I can tell by opening both files in a text editor, the both appear to be using:

XML v1.0

encoding: UTF-8

SVG version 1.1

But coded differently they are clearly.

Thank you,

tail-Zamzar.svg

Share this post


Link to post
Share on other sites

Bit of a guess but maybe EZCAD2 doesn't like <svg width="100%" height="100%" and needs explicit dimensions

Try exporting with Set Viewbox off

SetViewboxOff.png


Microsoft Windows 10 Home, Intel i7-9750H CPU @ 2.60GHz, 16 GB RAM, 500GB SSD, 1TB Whirlygig, NVIDIA GeForce RTX 2060
Affinity Photo - 24/05/20, Affinity Publisher - 06/12/20, KTM Superduke - 27/09/10

Share this post


Link to post
Share on other sites

Yes, that EZCAD2 uses path-oriented Transforms, where AD's SVG in contrast has defined group-oriented transformations. - So the whole is more or less due to a different SVG transformation definition approach and the way parsers and code generators do work and are setup between both apps.


☛ Affinity Designer 1.8.4 ◆ Affinity Photo 1.8.4 ◆ OSX El Capitan

Share this post


Link to post
Share on other sites

Thank you everyone for the advice. Disabling the "viewbox" option and setting the "flatten transforms" option did the trick. Now that I have something that works, I saved the settings as a preset called "EZCAD2".

The "add geometry" also works for the example I provided, but I have other projects with multiple independent elements that are not connected, I was also having trouble with.

I also learned I must convert text to curves before going to export. I know there is a check box in the export options to convert text to curves, but it didn't seem to work for EZCAD2. Very finicky software.

Share this post


Link to post
Share on other sites
3 hours ago, GeoQer said:

I know there is a check box in the export options to convert text to curves, but it didn't seem to work for EZCAD2

Designer is a bit inconsistent with the way this is done - if you convert to curves THEN export you get the curves inside a group element, if you convert to curves UPON export you get the curves without the group. I assume the group is added because it keeps the text together in the layer panel, which isn't really needed when done upon export.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.