Jump to content
Frozen Death Knight

Bad performance with GPU acceleration and tablets, especially when trying to resize your brush

Recommended Posts

Been trying the new GPU acceleration feature in the Beta and found out that brushes were very unresponsive when I used my tablet. I can't use ctrl+alt+L click to do simple things as changing brush sizes and the program became overall very unresponsive when using those tools.

Down below is a performance test using an 8k canvas with a 1k+ pixel sized round brush. The first test was using just a mouse for resizing the brush and filling the screen with paint, which worked fine. The problems started when I switched over to my tablet (you can see when I released the ctrl+alt+L click keybind and the brush resizing just kept going).

You can also see the lag when I wrote "Tablet now" on the canvas.

Share this post


Link to post
Share on other sites

Been trying the latest Beta and for the most part, hardware acceleration actually works! Massive brushes are significantly faster than in 1.8.5. Haven't been able to get my recording software to work, but I noticed significant speed boosts with 3k+ pixel sized brushes, which are practically impossible to use in older versions of Affinity. One problem I have however encountered is that there is some start-up lag happening at the beginning of your brush strokes, so if you do multiple brush strokes in rapid successions Affinity loses its more consistent performance like when OpenCL is turned off.

However, I have found a pretty program breaking bug when I attempted to do multiple strokes in rapid succession. Affinity loses pixel information in square like patterns on some brush strokes, creating artefacts like these (no, I did not erase anything):

1732579068_Skrmbild2020-09-29213202.png.586d3aeabcf83d348e09f32122e7d4cd.png

I tried to press undo to regain that lost canvas data, but it was permanently gone (of some reason the lost data reappears in some undo strokes but they remove the other data in some inverted pattern). Pretty important that this issue gets sorted out before the Beta ends, since this is a very serious bug.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.