Jump to content
Dazmondo77

All tools - curser changes to move tool - Mac 1.8.4

Recommended Posts

I'm assuming this is a bug - whatever tool I select, the curser changes to the move curser and doesn't show the correct curser until you use the selected tool, after use it quickly changes back to the move curser - I can't remember seeing this behaviour before?   


Mac Pro Cheese-grater (Early 2009)
2.93 GHz 6-Core Intel Xeon
48 GB 1333 MHz DDR3 ECC Ram
NVIDIA GeForce GT 630 - 2 GB
Ugee 19" Graphics Tablet Monitor
Mac OS Mojave 10.14.6

Affinity Designer, Photo and Publisher 1.8.3 + Betas when available

Binger.jpg.1f81574106cc2dea8ae65d0a572b9ef9.jpg
www.bingercreative.co.uk

Share this post


Link to post
Share on other sites

I cannot duplicate that behavior but I do not have a graphics tablet to test with. I notice from your sig that you have a Ugee graphics tablet monitor so I wonder if you are using yours & this somehow relates to this.

What happens if you use a mouse?


Affinity Photo 1.8.4, Affinity Designer 1.8.4, Affinity Publisher 1.8.4;  2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 40GB RAM; macOS 10.15.6
Affinity Photo 
1.8.4.186 & Affinity Designer 1.8.4.4 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 13.3.1

Share this post


Link to post
Share on other sites
19 hours ago, R C-R said:

What happens if you use a mouse?

R C-R I was actually using the mouse for the screen capture, but it was the same using the stylus - I quit and did a reboot and all seems fine - for now - I'm wondering if it was an OS prob defaulting to the standard mac arrow curser, as my system as been acting up a bit after the last (mid July-ish) mac security update, with some unusual hangs after boot-up where everything locks and seems un-responsive for a few minutes, then comes back to life???  

I see you're on Mojave, have you noticed any unusual hangs after the last security update? I've done various searches and can't find anything recent that relates to my prob 


Mac Pro Cheese-grater (Early 2009)
2.93 GHz 6-Core Intel Xeon
48 GB 1333 MHz DDR3 ECC Ram
NVIDIA GeForce GT 630 - 2 GB
Ugee 19" Graphics Tablet Monitor
Mac OS Mojave 10.14.6

Affinity Designer, Photo and Publisher 1.8.3 + Betas when available

Binger.jpg.1f81574106cc2dea8ae65d0a572b9ef9.jpg
www.bingercreative.co.uk

Share this post


Link to post
Share on other sites
34 minutes ago, Dazmondo77 said:

I see you're on Mojave, have you noticed any unusual hangs after the last security update?

No, at least nothing related to any update from Apple or Affinity.


Affinity Photo 1.8.4, Affinity Designer 1.8.4, Affinity Publisher 1.8.4;  2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 40GB RAM; macOS 10.15.6
Affinity Photo 
1.8.4.186 & Affinity Designer 1.8.4.4 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 13.3.1

Share this post


Link to post
Share on other sites
33 minutes ago, Dazmondo77 said:

I quit and did a reboot and all seems fine - for now - I'm wondering if it was an OS prob defaulting to the standard mac arrow curser,

I experienced in various Affinity app updates, since early APub betas, several times odd display occurrences which always felt rather like redraw issues than bugs. They always went away after a reboot, a simple app relaunch did not solve it. Even though a reboot is not required after an app update it obviously does support the app, may be to complete the installation and communicate properly with macOS.

25 minutes ago, Dazmondo77 said:

on Mojave, have you noticed any unusual hangs after the last security update?

No issues since this update here. But the update installation appeared a bit odd: it first prophecied an installation time of ~ 4 hrs, took actually ~30 min and, most weird, it rebootet twice during installation, in the 2nd reboot with a black screen for ~5 minutes. Also new to me: it appears at two different times in the installation protocoll:

505419040_macssecupdates2020july.jpg.10cc8c31c9d6e73e0d93657370b0593f.jpg


macOS 10.14.6, Macbook Pro Retina 15" + Eizo 24", Affinity in Separated Mode (documents merged)

Share this post


Link to post
Share on other sites

Dazmondo, this recent security update included graphic drivers for Intel GPU , could it have influenced your mouse appearance temporarily. For quite a few hardware models it also included EFI firmware updates:  https://eclecticlight.co/2020/07/15/catalina-10-15-6-update-is-now-available/   If you scroll down to the first comment you find a list of related models.

With the tool "SilentKnight" you can run a manual check especially for security updates (incl. the usually invisible updates for "XProtect", "Gatekeeper", "MRT"): https://eclecticlight.co/lockrattler-systhist/


macOS 10.14.6, Macbook Pro Retina 15" + Eizo 24", Affinity in Separated Mode (documents merged)

Share this post


Link to post
Share on other sites
On 8/5/2020 at 6:25 PM, thomaso said:

Dazmondo, this recent security update included graphic drivers for Intel GPU , could it have influenced your mouse appearance temporarily. For quite a few hardware models it also included EFI firmware updates:  https://eclecticlight.co/2020/07/15/catalina-10-15-6-update-is-now-available/   If you scroll down to the first comment you find a list of related models.

With the tool "SilentKnight" you can run a manual check especially for security updates (incl. the usually invisible updates for "XProtect", "Gatekeeper", "MRT"): https://eclecticlight.co/lockrattler-systhist/

I've not experienced any curser problems since the reboot Thomaso - but when I reboot, since the last security update, everything goes great, but around a minute after startup everything locks up, I can move the curser but not click or select anything, which can last around five minutes then everything just works as normal?   


Mac Pro Cheese-grater (Early 2009)
2.93 GHz 6-Core Intel Xeon
48 GB 1333 MHz DDR3 ECC Ram
NVIDIA GeForce GT 630 - 2 GB
Ugee 19" Graphics Tablet Monitor
Mac OS Mojave 10.14.6

Affinity Designer, Photo and Publisher 1.8.3 + Betas when available

Binger.jpg.1f81574106cc2dea8ae65d0a572b9ef9.jpg
www.bingercreative.co.uk

Share this post


Link to post
Share on other sites
7 minutes ago, Dazmondo77 said:

I've not experienced any curser problems since the reboot Thomaso - but when I reboot, since the last security update, everything goes great, but around a minute after startup everything locks up, I can move the curser but not click or select anything, which can last around five minutes then everything just works as normal?

That's odd, indeed. Does it occur in Affinity only? – A frozen cursor seems to be a known issue in macOS, for instance:
https://appletoolbox.com/mac-os-x-10-6-3-mousekeyboard-freezes-continue-more-fixes/

I would first try to fix it with a restart in Save Boot mode (Shift key on boot), this might reset some system preference files or 'kext' processes, which possibly did not get completely updated in your recent security update procedure, especially if your hardware was affected of the included firmware update, too.


macOS 10.14.6, Macbook Pro Retina 15" + Eizo 24", Affinity in Separated Mode (documents merged)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.