Jump to content
eobet

Sampling colors in a mask still samples underlying layer colors

Recommended Posts

Doesn't matter if I switch to the dropper tool and select current layer only, still doesn't sample accurate colors from the mask.

 

EDIT: I'm in the alt-click mask only view mode, btw.

Share this post


Link to post
Share on other sites

Masks are colorless -- they just are an alpha channel that controls the opacity of whatever they mask.


Affinity Photo 1.8.3, Affinity Designer 1.8.3, Affinity Publisher 1.8.3; macOS Mojave 10.14.6 iMac (27-inch, Late 2012); 2.9GHz i5 CPU; NVIDIA GeForce GTX 660M; 8GB RAM
Affinity Photo 
1.8.3.180 & Affinity Designer 1.8.3.2 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 13.3.1

Share this post


Link to post
Share on other sites

Hi eobet :)

Although as R C-R has mentioned Masks are colourless, you should still be able to select a Greyscale value when colour picking from the mask in isolation mode.

This is already logged as a bug with our developers, so I'll bump the log with your thread now. Many thanks!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.