Jump to content
HarryMcGovern

2 persistent bugs in Photo. Possibly others

Recommended Posts

The two things I really want fixed.

1. Placing or Applying images are being rotated when placed, unless taken with a camera.

2. Fonts are in random order when shown in the drop down lists. 

Anything else is as nothing compared to these two.
 

Share this post


Link to post
Share on other sites
9 minutes ago, Chris B said:

HarryMcGovern,

1. This sounds like an exif issue, do you have a sample you can attach?

2. Bumped the original report.

Yes, it is an exif issue, and I explored it in depth earlier. The conversation on the Facebook Group is as follows. Sorry it looks garbled. Copied it directly from the "Affinity Photo and Designer for iPad" Facegroup run by Paul Muddit. Posted March 4th 14:17 original post.

It's basically to do with the Keyword Orientation & camera type.  

 

Anything with Orientation set to 1 is OK

A DSLR type camera seems to be ok. Usually set to 1.

A screen capture. Shows almost no data, and certainly no Orientation keyword. Shows ok.

Anything taken with any iPhone or iPad gets rotated.

Other images seem to be random. Some do some don't get rotated.

... So something is determining the orientation of the image at import, and arbitrarily deciding it needs rotation - or not. Why? Why not just leave it as the user has it? Or offer a choice?

 

anyway, it'd be nice if these two could be fixed in a coming release. I'm not sure just now if it also applies to Designer, and to the Desktop packages as well. Haven't checked yet.

 

thanks

Robert

Q. When I place some images that are originally in portrait mode, why is it rotating the image 90 degrees?
I then have to fiddle about to rotate it again so it’s the right orientation.

No photo description available.
 
 
Comments
 
  • Paul Mudditt
    Paul MuddittoJUaDQAiBQe.png Hi Robert, fairly sure it’s to do with a bug in V1.8.0 where the EXIF data is not being read correctly which includes the camera orientation, It appears to be fixed in latest V1.8.2 beta which will likely be released soon.
    1
    Hide or report this
    • Robert Chalmers
      Robert Chalmers6zTRlzzrMzf.png Paul Mudditt Ah, thanks. I couldn’t figure that one out at all. Some images come in ok, others don’t. Let me experiment 🙂
      1
      Edit or delete this
    • Robert Chalmers
      Robert Chalmers6zTRlzzrMzf.png Paul Mudditt It seems some of the images I have have the Orientation metadata flag set, some don’t have it at all. Not even the Metadata tag.
      Interesting
      1
      Edit or delete this
    • Robert Chalmers
      Robert Chalmers6zTRlzzrMzf.png Paul Mudditt Further to that. 
      If Orientation is 1, it’s ok. Places right way up.
      If Orientation doesn’t exist, it places right way up if it’s a screen capture type. No camera.

      If it’s taken with an iPhone SE, and there is no Orientation meta tag, it rotates CCW 90’. If there is one, and it’s set to 6, it rotates CCW 90’.
      ... don’t ask me why the SE sometimes sets orientation and sometimes not. More experiments with iPhone and iPad to come.

      Orientation 6 for a RAW photo taken with iPhone 11 rotates 270’ on Placement.
      If it’s a photo of a paper drawing, Orientation 6, and CCW 90’
      And finally, iPad mini returns Orientation 6, and standard jpg image, CCW 90’.  
      So there we go... other cameras will have mixed results I’ve no doubt.

      And out of interest, my Panasonic LUMIX DMC-G5 returns Orientation 1, and loads correctly.
      1
      Edit or delete this
    • Paul Mudditt
      Paul MuddittoJUaDQAiBQe.png Robert Chalmers wow you have been busy ! Same photo loaded in the two versions, the beta version seems to show the metadata ok.
      Hide or report this
      Image may contain: text
       
       
      1
    • Robert Chalmers
      Robert Chalmers6zTRlzzrMzf.png Paul Mudditt Does it shows the word Orientation in the EXIF Data? Or anywhere else for that matter?
      Edit or delete this

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.