Jump to content
dCip

Edge lines on repeat patterm\n

Recommended Posts

Hello,

I'm trying to make a repeat surface pattern design using symbols. However, when I zoom in, I can see lines between the symbols both in Designer and in the exported png. I've tried to extend the color rectangle beyond the edges of the symbol but I still get lines.  Is there any way to prevent this.

Thanks for any help.

Problem.jpg

Share this post


Link to post
Share on other sites

Hi dCip

It sounds like an anti-aliasing artefact.

Here's what the super-helpful @MEB recommends. (Hopefully he's on xmas break at the moment.)

MEB

  • QA/Support
  •  
  • MEB
  • Moderators
  • staff.png.c356aec36362b0392a2d932c9ff350
  • 7,702
  • 26,173 posts

Hi Xeevis,
Welcome to Affinity Forums :)
As said above this is due to the antialiasing (the background colour is bleeding through the edges of the shapes). For pixel aligned vertical and horizontal edges this doesn't happen but with diagonal/round edges it causes the issues you are experiencing.

You can try select one of the shapes, go to the Layers panel, click the cog icon on the top left, then the Coverage Map button and drag the point on the left of the graph to the top (vertically) so both points (left and right) are both on top. Note this may not be applicable in all cases as it changes the antialiasing and may produce stepped lines in other places of the same object.

Other solutions if you want to keep the original objects perfectly aligned (no overlapping) is to add a third object behind them with the same colour of one of them just to hide/reduce contrast with the light colour of the background in the object's edges, add a thin stroke with the same colour as the objects to cover the gap or simply add (boolean operations) the objects if applicable/possible (you may have to delete some extraneous nodes or adjust the shapes before the add boolean operation to get a clean shape.


Affinity Designer & Photo  :  Win 10

Share this post


Link to post
Share on other sites
11 hours ago, dCip said:

I can see lines between the symbols

Position and size is whole pixels?


Affinity Store: Affinity Suite (ADe, APh, APu) 1.8.3.
Windows 10 Pro, Version 2004, Build 19041.388.
Dell Latitude E5570, i5-6440HQ 2.60 GHz, 8 GB, Intel HD Graphics 530, 1920 x 1080.
Dell OptiPlex 7060, i5-8500 3.00 GHz, 16 GB, Intel UHD Graphics 630, Dell P2417H 1920 x 1080.
Intel NUC5PGYH, Pentium N3700 2.40 GHz, 8 GB, Intel HD Graphics, EIZO EV2456 1920 x 1200.

Share this post


Link to post
Share on other sites

Thanks for the help.

Psenda, i'm working in whole pixels.

Roger C, I tried MEB's tips but the only thing that seems to work is dragging the shapes from the containing group layers and into the main Symbol layer. Will this affect how the Symbols feature works?

Thanks for the  help, d

 

test.png

Share this post


Link to post
Share on other sites
1 hour ago, dCip said:

Psenda, i'm working in whole pixels.

Would you provide a sample file?


Affinity Store: Affinity Suite (ADe, APh, APu) 1.8.3.
Windows 10 Pro, Version 2004, Build 19041.388.
Dell Latitude E5570, i5-6440HQ 2.60 GHz, 8 GB, Intel HD Graphics 530, 1920 x 1080.
Dell OptiPlex 7060, i5-8500 3.00 GHz, 16 GB, Intel UHD Graphics 630, Dell P2417H 1920 x 1080.
Intel NUC5PGYH, Pentium N3700 2.40 GHz, 8 GB, Intel HD Graphics, EIZO EV2456 1920 x 1200.

Share this post


Link to post
Share on other sites

Hi, thanks for the help

In 1.afdesign, one quarter of each circle is within the rectangle layer and is clipped by the layer. Only the part of the circle that is within the rectangle layer is visible on the live preview. But, if you zoom in you can see a line where the clipped edges of the circles meet.

In 2.afdesign, the circles are in the same X and Y position but not sublayers of the rectangle layer. However, the entire circle, ie the parts that are within and outside of the rectangle area, is visible on the live preview because there is no clipping. Also there is no line where the circles match. However the two circles overlap and appear to be only one circle.

I'd like to use the 1.afdesign method with the clipping. How do I prevent the line where the two edges meet in the live preview.

1.afdesign2.afdesign

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.