Jump to content
Steve108

Unable to save to Apple Photos since upgrade to Catalina 10.15

Recommended Posts

I have recently upgraded to Catalina 10.15 and I can no longer save changes made in Affinity Photo, the error message  Unable to Save Changes for “Edit in Affinity Photo” is displayed. I have discussed this with the Apple support desk, their position is that it is the responsibility of the third party supplier to ensure that their software is compatible.

Please would you advise when the software upgrade to achieve this compatibility will be available.

This is a major failure for anyone who uses Apple Photos as their library and Affinity Photo for processing.

 

Share this post


Link to post
Share on other sites

Check Finder, scroll down to Media, check to see if you have Affinity Photo, click and see if photo store in that location.


Cecil - North Carolina

iMac Retina 5K, 27”, 2019. 3.6 GHz Intel Core 9, 40 GB Memory DDR4, Radeon Pro 580X 8 GB. iPad Pro 10.5.

Continuous improvement is better than delayed perfection 

Share this post


Link to post
Share on other sites
3 hours ago, Steve108 said:

I have recently upgraded to Catalina 10.15 and I can no longer save changes made in Affinity Photo, the error message  Unable to Save Changes for “Edit in Affinity Photo” is displayed. I have discussed this with the Apple support desk, their position is that it is the responsibility of the third party supplier to ensure that their software is compatible.

Please would you advise when the software upgrade to achieve this compatibility will be available.

This is a major failure for anyone who uses Apple Photos as their library and Affinity Photo for processing.

 

BTW, I did get the same error notice you mention in your post. I just closed Photo, re-did the Apple Photos, doubled clicked on photo, Edit, Extension (...), Affinity Photo, picture opened in Affinity Photo, I made a few test adjustments, File, Save, File Affinity Photo, Close and it ask me if I wanted to Save, I clicked Ok. Location mentioned in above post.

i don’t truly know if Apple or Serif is at fault but this is a top issue, so many different threads.


Cecil - North Carolina

iMac Retina 5K, 27”, 2019. 3.6 GHz Intel Core 9, 40 GB Memory DDR4, Radeon Pro 580X 8 GB. iPad Pro 10.5.

Continuous improvement is better than delayed perfection 

Share this post


Link to post
Share on other sites

I had the same problem and noticed a couple threads here dating back to June where people had the same problem and same error message with Catalina.

 

I had cloned my drive before the upgrade so I was able to back out and return to Mojave.  I don't plan to upgrade to Catalina until this bug is fixed.

 

Affinity Photos Team, any update on any ETA to get this fixed.  It is a critical part of the workflow for many of us who use Mac and Affinity Photos.

Share this post


Link to post
Share on other sites

Hi jeffnles1,
Welcome to Affinity Forums :)
We are aware of the issues sending/saving back files from Apple Photos/Affinity Photo (issues being followed here too). We are investigating them - Edit With and Edit in Affinity Photo extension - no eta for a fix, sorry. Thanks for your report/support. I'm sorry for the inconvenience this is causing you.

Share this post


Link to post
Share on other sites

Hi MEB,

Thank you for the confirmation that there is a known fault. It is disappointing that you are unable to provide a date for the fix. 

Please would you suggest a work around that I can use until you issue the fix.

 

Share this post


Link to post
Share on other sites

Hi Cecil,

Thank you for the reply. It appears from MEB that this is a known fault.

BTW I can save files from Affinity to disc but I can not save them back to Apple Photos.

Share this post


Link to post
Share on other sites
7 hours ago, MEB said:

Hi jeffnles1,
Welcome to Affinity Forums :)
We are aware of the issues sending/saving back files from Apple Photos/Affinity Photo (issues being followed here too). We are investigating them - Edit With and Edit in Affinity Photo extension - no eta for a fix, sorry. Thanks for your report/support. I'm sorry for the inconvenience this is causing you.

MEB,

Thanks.  Like Steve108 said, it is a disappointment no ETA on a fix.  I will hold off on installing Catalina as long as I can.  I really like Affinity and the Photos extension has become such a part of my workflow that it would be hard to imagine working without it.

 

Hope you all can figure it out and get it fixed soon.

 

Jeff

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.