Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

FxRphoto

Members
  • Posts

    41
  • Joined

  • Last visited

Posts posted by FxRphoto

  1. Hello arnim,

    I am working on both an iMac 2012 and a MacBook Pro 2015 with OSX Mojave.

    I updated to Nik Collection 2 last week and I mostly use SilverEfex. On both system, when I open a TIFF file from AP 1.7 via the Nik plugin, I no longer have the "updating fonts" message and the plugin doesn't cause AP to freeze.

    44 minutes ago, arnim said:

    So what is the reason Nik2 will work better than Nik2018 according to your findings?

    Actually, I don't know...

    I admit that my "perfectly works" assertion is a bit overstated since I have not made a lot of testing so far. But it seems to work for me...

    The bug comes from DXO, not Affinity. But I think that they do not care very much about the Nik Collection, that's what this new version demonstrate (just check the DXO forum and count the number of answer posted by the team on Nik...). The same UI as the free google version,  not even a dark mode for Mojave, nothing new aside some useless presets since I bought my first version (for 150$) from Nik Software back in 2014. I don't need something new every month, I prefer stable tools. But here, It seems that DXO has followed the way of Google, and just bought Nik to integrate its algorithms within their own software.

    As a conclusion, I paid 60€ last year for a first upgrade, I never used because it never really worked on AP 1.6.7, then I paid 60 more euros last week and now it seems to work. But by the time, I improved my skills with AP and do most of my work with its tools to the same results. So, I think I won't pay again for Nik until DXO clearly decide to work on it.

    Fx

    P.S.: Sorry arnim, maybe it is a bit far from what you asked... 

     

  2. Hi everybody,

    The latest release (version 2, released last week) of Nik Collection works perfectly with AP 1.7,  but I don't know if it's worth the upgrade price, since it not really seems to have something "new"...  (At least, I didn't see anything new for now)

    Anyway, it works (and that is new!). So if you really need the plugin, maybe you can upgrade.

    Fx

  3. Hi everybody,

    For me the last week update from DXO (1.2.0.18) works fine in AP 1.67 (DXO statement say that they have improved the compatibility with Affinity products). But in the AP beta 1.7.0.100 version all the plugins freeze with a black window and the "updating fonts" message.

    I think DXO is lagging behind Affinity in their update roadmap...

    But if they have fixed the problem in the stable version of AP, there's still hope ! 

    Fx

  4. Hi,

    I just made a quick look in Affinity Photo beta 1.7.0.99. Not enough time to dive further in, for now. But, once again, might you please add a choice for TIFF compression, or at least don't use LZW. ZIP would produce much better results. 
    LZW is totally useless when working on 16bits files, worst of all, it increase the file size about 10 to 20%. Why do you go on with a default LZW compression ?

    Adding a choice for compression parameters is not a fancy feature, almost every high grade photo software has this.

    Regards,

    Fx

  5. 4 minutes ago, Fixx said:

    It is a problem for few people. Normally it does not affect work flow and quality any way.

    Of course it does not affect neither the workflow or the quality. But the purpose of compression is to save space, not to increase it. 

    For 16bits images LZW compression is not only useless but it produces files that are larger than uncompressed ones. And that's the point.
    Having the choice to use it or not is a key feature, and I guess, not so difficult to implement.

    A better choice would be to offer a ZIP compression with several degrees of compression (the best method to lossless compress 16bits files), but it is probably a more difficult feature to add.

    Regarding the fact that it affects a few people, since it is not clearly displayed in Affinity Photo, the only way to see that a LZW compression is actually applied to all the files saved in TIFF, is to check the properties of the files. Not many do that, indeed. It took myself months to notice it. Not a reason to consider that it's not important. 

    And, as a reminder, Affinity Photo is, to my knowledge, the only software not to have the choice of TIFF compression. 

    Fx

  6. On 7/5/2018 at 6:47 PM, R C-R said:

    It should work basically the same way if you just select those layers without grouping them, copy that to the clipboard, & then record a macro with the paste step in it.

    After further experiment, the group is necessary. I tried without grouping, just with an adjustment layer and a fill layer with the gradient as a child. It's odd but only the layers are pasted, not the gradient. If I just make a group with the adjustment layer and its child including the gradient, then it works fine. 

    Fx

  7. 13 hours ago, R C-R said:

    As I understand it, this works because the paste step saves whatever is on the clipboard at the time the macro is recorded as part of the macro.

    I guess so

     

    13 hours ago, R C-R said:

    It should work basically the same way if you just select those layers without grouping them, copy that to the clipboard, & then record a macro with the paste step in it.

    Exactly. I use a group just for the purpose of the gradient since it is the only way to apply several adjustment to the same fill layer.

    The only thing to keep in mind is that, with this method, everything that is copied will be pasted when the macro is runned, even the background layer. So, be sure not to copy it before creating the macro. Otherwise, the same background used to create your macro will always be pasted when you use that macro. (obvious, but it worth remind it)

    Fx

     

  8. Hi everybody,

    I just found a trick with non recordable features. 

    I wanted to create a macro that sets a group of adjustment layers and a fill layer with a gradient to emulate an adjustable neutral density gradient filter. But when I tried to record the macro, I realized that the gradient tool couldn't be recorded (the position of the fill layer was also difficult to set). I created this set without recording and copied the group. Then I recorded the macro with a simple clear selection and paste. 

    I tried this macro several time and it always creates the whole gradient set, even if I copy something else, or close the app, or shut down the computer. I tried with several macros created with the same process and they seems to work fine for now and it helps a lot.

    It is not very academic and I don't know if it's a correct way to bypass the limitations of the macro feature but maybe it is worth to have a look at it and see if there is issues with that method.

    Regards
    Fx

  9. 1 minute ago, Christoph L said:

    Checking the version number of the plugin in AP was the first thing I did - it's 1.12.15

    1.12.15 is the version number of the whole Nik suite, you need to check the individual plugin version number and compare with the standalone one. For instance in Color Efex Pro, the new version number is 5.0.0.0 (for both standalone and plugin) and the old one is 4.3.25.0

  10. Hello Christoph L,

    This is actually the same install method I have described above in this thread.
    I am quite sure you are running the old free version of the plugin (just check the version number of the plugin in AP). 
    Stand alone apps and plugins work separately. You can run both of them at the same time if you want.

    So it helps, but that doesn't solve the problem, since the last paid version from DXO remains unusable as a plugin in AP. 

    (they have released a 1.12.15 update indeed, and don't seem to bother informing their customers. We don't even know what changes they have made.)

    Fx

  11. Hi OldRadioGuy,

    Actually, the new version doesn't work at all as a plugin for Affinity Photo for Mac. It freezes during the "preparing image" process and causes AP to freeze as well (need to use the force-to-quit command).

    Better to stick with the last free version from DXO (1.12.12) or the Google version, no major changes anyway. 

    You will find some other threads on that topic like the one dominik has posted above, or this one

     

  12. Hi Chips, 

    For me Photo Mechanic from Camera Bits is one of the best professional choice for photographers but it comes at a cost. (about 150$)

    This is an Adobe Brige-like software, no catalog. However, Camera Bits is planning to release is 6th version this year, maybe with cataloging option.

    They have a long experience with their soft, the first release of Photo Mechanic was in 1998, and it is a very good tool, fast and efficient. The support and forum are quite good too.

    One limitation for now,  is that the soft don't display .PDF or .afphoto previews.

    XNView is also a well known free software, but a bit tinkered, in my sense.

    There is a bunch of other software, more like alternatives for Lightroom, and you will find a lot of thread on this topic, like the one above, on this forum.

  13. No,

    20 minutes ago, Mohammed Elkhamissy said:

    thanks, i will try it, but probably your are using the Google version not DXO

    No, as I wrote above, for the plugins, I use the last free version from DXO, which is 1.12.12
    Anyway, this installation is the same for any version you want to use, even the latest paid release (1.12.14). I don't think that the installation path could change anything in the plugin working.

     

    Fx

     

     

  14. Hi firstdefence,

    Yes, 1.12.12 works fine in both standalone and plugin versions (this is the latest free version from DXO). Better keep a copy of that one, there isn't any major changes in the latest paid release anyway...

    If you already have the latest paid version from DXO (1.12.14), the standalone app works fine, but the plugins don't work and cause AP to freeze (you have to use the force-to-quit option). So you can use the new standalone alongside the old plugins (just replace the new plugins folder by a backup of the old one)

    Fx

  15. 8 hours ago, mikerofoto said:

     

    you got me thinking that I have the wrong version installed and double checked.

    the DxO version will show upper right corner Nik by DxO and not Nik Collection like on your screenshot.

    here's mine

     

    Screen Shot 2018-06-11 at 7.04.42 PM.png

     

    Hi Mikerofoto,

    This screen is the new paid version, but in standalone version and on Mac at least, there isn't any issues running the standalone app. 

    In my post I was referring to the plugin version. The difference is seen in the "save" button down-right of the UI, in the plugin running in AP it is a "OK" button (to apply the plugin to a layer instead of overwriting the file)

    Fx

  16. Hi Mikerofoto,

    I have tried your installation according to the screenshot you have provided and it doesn't work for me. Nik still freeze during the "preparing image" process.

    Have you check this really is the new version that you are running ? Sorry to ask but the first link they send to me after purchase was actually the latest free release 1.12.12 instead of the 1.12.14 paid one. They apologized for that, but first I have thought that everything worked perfectly.
    The solution I use for now, is to install the new version in standalone and the old one for the plugins. 
    Oddly, when I check the version number, it shows the old plugin number with the new suite number version, e.g. Silver Efex pro shows version 2.0.0.25 (1.12.14) instead of 2.0.0.25 (1.12.12) or 5.0.0.0 (1.12.14).

    Fx

     

    1412286211_Capturedcran2018-06-1118_40_24.thumb.png.a976d37377ae1715011c1961e078045a.png

     

  17. Hi everybody,

    The only way I found so far to use Nik plugins in Affinity for Mac, is to  re-install the latest free version of the plugins (they work quite well indeed...), and the new version in standalone. 

    Not really a solution but in the meantime...

    There is a thread on the DXO forum : https://feedback.dxo.com/t/nik-affinity-interoperability/3203
    Maybe if some of the huge community of Affinity users post some messages on it, the DXO team will acknowledge that there is not only Adobe users on earth. ;)

    Fx

  18. Hello everybody,

    I have just noticed that the TIFF files are always LZW compressed, even when you open them uncompressed and then just hit command/S to save them.

    It is indeed a big issue because we ought to have the choice regardless of wether or not it harms the files. 

    Why the hell Affinity Photo is the only software not to offer that simple feature ?

    Fx

    As a post scriptum and To confirm (if necessary) what is said above :
    my 36MB DNG file processed in Iridient Developer and saved uncompressed in 16bit TIFF is a file about 130MB. Opened in AP and just exported without any changes, it become an LZW compressed TIFF file about 137 MB. Not a lot, but still. And why using compression if it's not for saving space ?

  19. R C-R,

     

    I have created an .afphoto file with basic black & white conversion (to see the obvious change). No more layers.

     

    Indeed, GC10 always shows the original color preview and don't really manage the file properly, since when I double-click on it, the soft  tries to open it with my raw converter instead of AP !


    The OSX interface just shows the same color icon (maybe I need to restart to refresh the icon file) but a small, totally useless b&w preview in Quick look. Of course, it opens the file correctly in AP.


    As for Photo Mechanic, It doesn't show any preview, but it opens the file correctly.

     

    I do not use native files of any software so much, I prefer the .tiff format. That's why I missed that.

     

    I have seen that there is some feature claims on the Photo Mechanic users forum regarding the .afphoto files. Maybe one day the Camera Bits team will include this file format in their soft...

     

    Regards,

    Fx

  20. 5 minutes ago, R C-R said:

    At least for me, GC9 does not offer much that is particularly useful for .afphoto files. It does not always show an image preview or shows what appears to be a thumbnail from the original image instead of an accurate preview of the edited version. I am not sure what that is but it seems to have something to do with the layer structure of the file. The Mac Quick Look feature & Finder views both show the native Affinity format files as they appear in the app, so maybe it has something to do with GC9 not being able to access that.

     

    I have GC 10 installed on one of my computers. I check if it works with the native Affinity Photo files and  I come back to you in a minute.

     

    Fx

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.