Jump to content

Recommended Posts

When exporting to PDF I get the following message.

I have seen in previous posts that the issue may be connected to use of some fonts but I don't believe this is the case in this instance as Bell MT was used throughout.

Any suggestions or work arounds would be greatly appreciated. 

Thank you! 

image.png.c46685f98372f5a28ed567748fb7776c.png

Share this post


Link to post
Share on other sites

Hi Kprice,

Welcome to the forums :)

Sorry to hear you're having trouble! Could you please try the following:

1. Create a folder called 'temp' on the root of your C:\ drive so you have C:\Temp\
2. Run 'PDFLibLogging.reg' - this will insert a registry entry that enables logging for PDFLib
3. Run Affinity and export to PDF
4. Go to C:\Temp\ and view the PDFlib.txt file to see the log.
5. Run 'PDFLibLoggingRemove.reg' to remove the logging as this can cause slowdown and crashes if the C:\Temp file is removed.

Please attach the .txt file here, many thanks in advance!

PDFLibLoggingRemove.reg

PDFLibLogging.reg

Share this post


Link to post
Share on other sites

Thanks for that, your log isn't showing any usual signs of export failure (ie a corrupted font). Have you tried exporting the file to a different location?

Could you please provide a copy of your Affinity file and any fonts used (such as Bell MT) to the following link, so I can try exporting this here? What PDF export settings are you using please?

https://www.dropbox.com/request/AVrg04sVfPqd7iJ80HXU

Share this post


Link to post
Share on other sites
2 hours ago, Kprice said:

Hi Dan, 

These are the settings i'm using. Tried exporting to a number of locations.

image.png.1991e1280f2dedc1ea06416404d79791.png

JPEG or PDF? That looks broken to me.


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.7.3 | Affinity Photo 1.7.3 | Affinity Publisher 1.7.3 | Affinity Designer Beta 1.7.x.x | Affinity Photo Beta 1.7.x.x | Affinity Publisher Beta 1.7.x.x

Share this post


Link to post
Share on other sites

Thanks for that kprice :)

17 hours ago, Old Bruce said:

JPEG or PDF? That looks broken to me.

This does look a little odd, but it's not something that I can replicate nor is it related to this issue, I suspect it's a glitch in mouse pointer detection when taking a screenshot (assumedly using the Windows snipping tool).

Your PDF is failing to export due to 2 separate objects, on page 7 & page 10. The text objects, circled below, both have a very strange decoration applied to them, as they both have a Textured Line style applied to them as a decoration, with a Linear Gradient fill, one end of which has artificial noise and a mitre setting of 1.414. Were these decorations intentionally added? 

image.pngimage.png

eb105e522cdfdb3a410121ffaa3cc1ab.gif

Removing the decorations from these two text objects will allow your PDF to export correctly, I'm not 100% certain on why this combination is causing the export to fail but I've logged it with our developers as a bug now :) 

Share this post


Link to post
Share on other sites

Strange glitch, I don't believe I changed the style of the asterisks. 

Removed and working great now, thank you so much for that :D

Have a great day.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.