Jump to content

[Fixed] Bug: Adobe Bridge Opens image in Publisher when Photo is selected

Recommended Posts

I'm not sure if this is an Adobe Bridge bug or a Publisher bug, or a Photo bug.

I have my Adobe Bridge install set to open images in Affinity Photo as the default. And that works fine. However, if I select and hold down to "Open with Affinity Photo" it opens in Publisher instead. It only started doing that very recently. I tried "Open with" pointed at some other editors and it worked fine. It only makes the error to open in Publisher when Photo was selected.

Running Mojave 10.14.5 

Publisher Beta

Photo 1.7.0

Adobe Bridge

Link to comment
Share on other sites

3 hours ago, GabrielM said:

Hi @skiphunt,

I'm not getting this. Everything is fine. I suggest you contact Adobe as we have no control over their "Open with" dialogue. 



There was an Adobe Bridge update yesterday... but it's still doing what I described above. Not a big deal though. And, I really can't contact Adobe about it as you suggest because I'm using a beta of Publisher. They will almost surely blame the "beta". 

I'll see if it resolves itself after the public version of Publisher is released so that it takes the "beta" classification out of the picture.

Also... it seems to ONLY be related to "open with" when attempting to "open with" Photo. If I "open with" any other app, it works fine. It's ONLY "open with" Photo that opens in Publisher. It's like Bridge has Photo and Publisher confused with regard to the "open with". 

But yes, if you can't reproduce the same behavior, I get that there's nothing that can be done on the Affinity side. 

And, it's not really a show stopper at all. But a bug that is somehow related to a confusion with Publisher. As I stated in my post, I don't know if it's Photo, Bridge, or the Publisher Beta that's at fault. Just thought I'd pass it on. 

Link to comment
Share on other sites

I don't understand how Bridge could know if you wanted to use the beta or the shipping product. I have the same issue with HoudahSpot 5 but there doesn't seem to be any option to change the default other then uninstall the beta? That may be a small issue to me as well since I am a continued beta tester most of the time.

Link to comment
Share on other sites


  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.