Jump to content
Dazmondo77

Serious PDF bug AAAAGGHHH

Recommended Posts

Yeah I know we shouldn't be using the betas for production work - but it's worked great until now - 

My client has got back to me regarding his artwork with areas over 320% ink density, which I a bit of a prob to sort in affinity, but I've sorted through masking in Photo.

So now I'm creating print ready PDF's (tried both PDF/x 2001a and 2004), it's rasterising everything, whereas my previous set of PDFs for this job where as expected with text, logos and barcodes etc as vector information the only way I can manage a workaround is to take all the raster elements and group them, duplicate and rasterise and then create the PDF set to rasterise nothing 

 

Using El Capitan on 2009 Mac Pro - Designer 1.7.0.5   

See attached (note - includes offensive language)

AV01_cdbooklet_spread.afdesign


Mac Pro Cheese-grater (Early 2009)
2.93 GHz 6-Core Intel Xeon
48 GB 1333 MHz DDR3 ECC Ram
NVIDIA GeForce GT 630 - 2 GB
Ugee 19" Graphics Tablet Monitor
Mac OS 10.11.6 El Capitan

Mainly use Affinity Designer & Photo 1.7.0 +  Publisher Beta 1.7 latest Betas when available

Binger.jpg.1f81574106cc2dea8ae65d0a572b9ef9.jpg
www.bingercreative.co.uk

Share this post


Link to post
Share on other sites

I've tried re-booting and creating PDF's from photo plus ditched the layer masks and used blend range instead (much better results and easily editable) and none work apart from flattening down the raster groups and creating a PDF/x 2004 setup to rasterise nothing - hopefully they'll accept them as they require PDF/x2001a


Mac Pro Cheese-grater (Early 2009)
2.93 GHz 6-Core Intel Xeon
48 GB 1333 MHz DDR3 ECC Ram
NVIDIA GeForce GT 630 - 2 GB
Ugee 19" Graphics Tablet Monitor
Mac OS 10.11.6 El Capitan

Mainly use Affinity Designer & Photo 1.7.0 +  Publisher Beta 1.7 latest Betas when available

Binger.jpg.1f81574106cc2dea8ae65d0a572b9ef9.jpg
www.bingercreative.co.uk

Share this post


Link to post
Share on other sites

Hi Dazmondo77,

I believe this is a known issue - that is being caused by Artboards. If I delete an both artboards (will need to be done as two separate docs to maintain page size) and then export it is going out correctly (at least from what I can see). Would you be able to export the two attached AFDesign files please and just double check the results are acceptable and correct (as you're much more familiar with the issue).

Spread1.afdesign

Spread2.afdesign

Share this post


Link to post
Share on other sites

Perfect mate - I had a similar issue a year or so ago with a duplex flyer setup as art boards not reproducing images with layer effects and transparency correctly and changing to single documents sorted the problem -

Hope it gets sorted soon

Thanks again boss


Mac Pro Cheese-grater (Early 2009)
2.93 GHz 6-Core Intel Xeon
48 GB 1333 MHz DDR3 ECC Ram
NVIDIA GeForce GT 630 - 2 GB
Ugee 19" Graphics Tablet Monitor
Mac OS 10.11.6 El Capitan

Mainly use Affinity Designer & Photo 1.7.0 +  Publisher Beta 1.7 latest Betas when available

Binger.jpg.1f81574106cc2dea8ae65d0a572b9ef9.jpg
www.bingercreative.co.uk

Share this post


Link to post
Share on other sites

Have noticed another bug with 1.7.0.5 related to this job that effects vectors placed inside vectors - ran tests and they aways rasterise on output to pdf. taking out of the vector container and placing over the top outputs vector - ran test with previous 1.7.0.4 and it works normally

Caused me loads of bother with the bar code but sorted a work around and now sent off the the printers

I did start a fresh topic on this at: 

 


Mac Pro Cheese-grater (Early 2009)
2.93 GHz 6-Core Intel Xeon
48 GB 1333 MHz DDR3 ECC Ram
NVIDIA GeForce GT 630 - 2 GB
Ugee 19" Graphics Tablet Monitor
Mac OS 10.11.6 El Capitan

Mainly use Affinity Designer & Photo 1.7.0 +  Publisher Beta 1.7 latest Betas when available

Binger.jpg.1f81574106cc2dea8ae65d0a572b9ef9.jpg
www.bingercreative.co.uk

Share this post


Link to post
Share on other sites

Hi Dazmondo77,

I've spoken to development about this issue with regards to your file and can confirm that the bug of everything on artboards getting rasterised has been fixed. However it is the Unsharp Mask Live Filter (even though it is hidden) that is causing the rasterisation to occur.

To ensure Live Filters are being output correctly, the whole tree up from the Live Filter will get rasterised (which includes the artboard). Unfortunately this means that you'll either have to delete the Live Filter (in this case should be ok as its not enabled) or merge it with the raster elements of the document.

I hope that helps!

Share this post


Link to post
Share on other sites

Thanks Sean - Thats one to look out for as I've used the unsharp mask feature quite a lot - no worries.

In Designer 1.7.0.7 I've made a group consisting of a circle with the unsharp mask filter applied and dragged it to my assets panel so I have it on hand, and deleted the offending USM filter, then saved as PDF/x 1a 2003 and views in Acrobat pro 9.9.5 and both pages are now perfect - all vectors are vectors

ACE! 


Mac Pro Cheese-grater (Early 2009)
2.93 GHz 6-Core Intel Xeon
48 GB 1333 MHz DDR3 ECC Ram
NVIDIA GeForce GT 630 - 2 GB
Ugee 19" Graphics Tablet Monitor
Mac OS 10.11.6 El Capitan

Mainly use Affinity Designer & Photo 1.7.0 +  Publisher Beta 1.7 latest Betas when available

Binger.jpg.1f81574106cc2dea8ae65d0a572b9ef9.jpg
www.bingercreative.co.uk

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×