Jump to content
lexislav

Designer file import bugs

Recommended Posts

Importing Designer (Last MAS version) to Publisher (1.7.0140) is not smooth as it should be.

I have run into those bugs:

  1. margins are not imported
  2. guides are not imported
  3. some text frames looks different (see screenshots attached)

Note: Sorry I have to delete rest of design, but I could not share more client's details.

publisher import designer with bugs.png

original file margins and guides.jpg

publisher imports designer with bugs.afdesign

Share this post


Link to post
Share on other sites

HI lexislav

The guides do seem to be imported but the margin does not so I shall get that passed over tot he development team. 

In terms of the text, I think this was actually originally handled incorrectly in Designer and is not being displayed correctly in Publisher. The text has a character leading override applied which is not honoured when going to superscript in the current Designer release. Superscript has changed in Publisher. the typography superscript is not only available if the font itself supports is. There is also a another superscript drop down which behaves more like it did in Designer. What the superscript also does do now in Publisher is it honours the leading override as it's supposed to. So basically this was designed around a bug in 1.6 which is now fixed in 1.7

Cheers


Serif Europe Ltd - Check the latest news at www.affinity.serif.com

Share this post


Link to post
Share on other sites

Hi Chris,

thanks for the explanation about text issues. Would 1.7 eventually convert/correct such bugs?

Guides are not imported for me. So You are lucky to get them. My guides manager show no guides for the document. Hopefully be fixed too.

Chhers

 

Share this post


Link to post
Share on other sites
5 minutes ago, lexislav said:

My guides manager show no guides for the document.

Try this one neat trick... Open the Guides manager and tick the % check box and un check it again if you want. That seems to work for me on some documents where the guides don't show. It may work with imported or it may not. Most likely a bug I haven't been able to fully consistently reproduce.


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.4

Affinity Designer 1.6.1 | Affinity Photo 1.6.7 | Affinity Publisher beta 1.7.0.293 | Affinity Photo beta 1.7.0.120 | Affinity Designer Beta 1.7.0.9

Share this post


Link to post
Share on other sites
12 hours ago, Old Bruce said:

Try this one neat trick... Open the Guides manager and tick the % check box and un check it again if you want. That seems to work for me on some documents where the guides don't show. It may work with imported or it may not. Most likely a bug I haven't been able to fully consistently reproduce.

Thanks for the tip. Unfortunately, it didn't work for me (at least in this case). But will keep it in mind…

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×