Jump to content
Friksel

[AD win] Wordwrapped lines don't respect set leading

Recommended Posts

When text gets wordwrapped inside a textblock (or by pasting text into an existing textblock) all wordwrapped lines don't respect the leading and we're not able to set leading for those lines in the properties. The only way to get the right leading (as set in properties) on the wordwrapped lines seems to be to add linefeed-characters to ALL LINES by hand. 


 

Share this post


Link to post
Share on other sites

@Sean P Here's a screencapture. At first I just write text after existing text. You can see wordwrapped-lines have a different leading then existing lines. Notice that the properties don't change in the Character panel. That's also the case when selecting the new lines, the properties remain the same wherever you click.

After that I selected part of the textblock and pasted without styling (ctrl-alt-shift-V) a lorem ipsum. Here you can see also overwritten text get a different leading.

I didn't record this, but I can tell you here that when I select the wordwrapped text (so with the wrong leading/line-height) and change the leading, the text indeed changes the leading visibly on screen. But still it's a different leading as set in non-wordwrapped lines for some reason.

Hope this helps.


 

Share this post


Link to post
Share on other sites

Hi Friksel,

Would you be able to attach the document as in the state at the start of the video please? It will allow me to investigate this better! I've just tried again by typing a word that is longer than the frame size, but still this is wrapping for me.

Share this post


Link to post
Share on other sites

Thanks for the document - after looking at it I can see that your document has been created rather weirdly.

You've added a new paragraph at the end of every line. This means that your 'leading' is actually a leading value of 7.7pt plus an additional 1.5pt spacing from the Space Before Paragraph attribute. So in your video when you type it wraps the text with a leading of 7.7pt and not the 9.2pt you think is applied.

Judging by your document it looks like you've added these paragraph markers so that you can line the text up on additional lines using tab stops. This is bad because if you ever need to resize the text frame it will break the flow of the text giving you horrible gaps because of the paragraph markers and tab stops being moved. This can be solved by setting the First Line Indent and Left Indent correctly. If you set the First Line Indent to 0pt and the Left Indent to 15pt you will get a result that looks exactly like your text frame, but this time flows correctly without the need for any additional tab stops or paragraph markers. See the attached documentOriginal.thumb.png.f222bc098709b41d7a25d08f40cbffc9.png

Corrected.thumb.png.59c15c70a45a9cad228bab9e530daf65.png

Wordwrap Corrected.afdesign

Share this post


Link to post
Share on other sites

@Sean P Ah okay, I didn't know that. That makes a lot more sense then the way I constructed the document now indeed. I sent you just a simplified version of the full document. Changed it here and it works fine as you explained now. So this one can be closed. Thanks for your effort and quick response.


 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×