Jump to content

Recommended Posts

I am new to using this type of application. I purchased it to make ads and other things for my company. My logo is in a PNG format but when I go to apply it to the ad I'm trying to create it has a white background. How do I fix this? 

Share this post


Link to post
Share on other sites

Hi bcr2017,
Welcome to Affinity Forums :)
Which application are you using? Affinity Designer or Photo?
If you are using Affinity Photo, select the logo layer then go try the Erase White Paper filter (menu Filters ▸ Colours ▸ Erase White Paper). This may or may not work depending on the company logo colours (it will not work if it uses white or grey as those parts will become transparent or semi-transparentif used directly).

Another option is to use the Blend options to remove the white. See my reply here for an example (this applies to both Affinity Designer and Photo). 

Without seeing the logo/file is difficult to give you more precise directions.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.