Jump to content

Batch Macro has a Different Result then just Running a Macro... Why?

Recommended Posts

So I am trying to edit a star lapse I took by recording my macro then re applying it to a batch. However the results are way different when I do this. How come? I know the Macro is good because when I run it on just a single image it looks great. However when I run it as a part of a batch it doesnt even look the same. Whats the point of the batch processor if it doesn't work? I was really hoping to use affinity over Adobe products but its looking like for mass image editing nothing beats adobe. Might have to just suck up and pay to stupid monthly cloud subscription. ugh. Anyways the first image is my original macro ran on just a single image and then the image on the right is from the batch, and yes I used the same macro for both. 

Image 1 



image 2


Link to comment
Share on other sites

Here is a link to the Macro file I used: 

https://www.dropbox.com/s/hfmf9wx9d3eftbn/Watertower Macro.afmacro?dl=0


Just in case it helps anyone figure out if I am doing something wrong. Also I did not raw develop the photo before running the macro. I made sure everything in the raw develop was unchecked before moving forward with making the macro. 


The Files are from a GH5 RAW RW2 files.

Link to comment
Share on other sites

Your mention of raw has confused me. I would not normally "raw develop" a .jpg file (though I know that it's possible).

What did you start with? What did you do to it before running your macro in the case that worked as you want?

Edit: Are you starting with a raw file, putting it through the Develop Persona but not doing anything other than hit Develop? If so, that might explain your problem, as I don't think that Affinity Photo can handle a raw file without going through the Develop Persona, and the batch macro processing won't use Develop at all (as far as I know). It's kind of surprising to me that you'd get anything if you're trying to feed raw files into the batch processing.

-- Walt

Desktop:  Windows 11 Home, version 22H2 (22621.1413) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 
Laptop:  Windows 10 Home, version 21H2 (19044.2728) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
        Affinity Photo 1.10.6 (.1665) and 2.1.0 and 2.1.0. beta/ Affinity Designer 1.10.6 (.1665)  and 2.1.0  and 2.1.0 beta / Affinity Publisher 1.10.6 (.1665)  and 2.1.0  and 2.1.0beta
iPad Pro M1, 12.9", iPadOS 16.4.1 (a), Apple Pencil 2, Magic Keyboard

      Affinity Photo 1.10.7 and 2.1.0 and 2.1.0 beta/ Affinity Designer 1.10.7 and 2.1.0 and 2.1.0 beta/ Affinity Publisher 2.1.0 and 2.1.0 beta

Link to comment
Share on other sites

I started with a raw file like I said above Panasonic GH5 RW2 file. When you open a raw file it auto takes you to the develop. Well I know that when I batch a bunch of raw files it won't batch develop them so I usually zero out everything in the Raw Develop persona and then develop with no changes because I uncheck everything. That way I know it best represents the end result. Then I apply my Macro from that raw photo with no raw processing done to it. Once it looks how I like it, I save the macro to apply to my 500 plus images. But then they turn out a lot darker like it skipped some steps. 


So I then re open a RW2 file and apply the macro manually through the library and it works like it should. So I know the macro is good. Just something wrong with the way it applies it when doing a batch. Could it be because they are raw? That would be a horrible flaw from affinity. Almost everyone I know only deals with raw images. 

Link to comment
Share on other sites

The only thing that seems to affect the image to match a similar effect is turning off the Brightness and Contrast and or the HSL adjustments, so, are those adjustment layers showing and are they on (checked) when the macro ends? 


Are they checked to action within the macro?

iMac 27" Late 2019 Fully Loaded and running Monterey 12.6.6, iMac 27" Late 2013 running Catalina 10.15.7 - Affinity Designer, Photo & Publisher V1 & V2, Adobe, Inkscape, Vectorstyler, Blender, C4D, Sketchup + more... XP-Pen Artist-22E, - iPad Pro 12.9 B|  

Affinity Help - Affinity Desktop Tutorials - Feedback - FAQ - most asked questions

Link to comment
Share on other sites

5 hours ago, owenr said:


The problem is raw development in a batch job.


On my Mac, if you run a batch job with raw files when the raw engine choice in Develop Assistant is Serif (Windows users will have no alternative), then the raws are developed with the Serif engine as if you had specified 16-bit output, no lens correction, no noise reduction and no tone curve in Develop Assistant, regardless of the actual settings in Develop Assistant, and then an additional darkening is applied. (The same thing happens when using the Place command to import a raw file into an AP document, but also the engine used is Serif regardless of whether Serif or Apple is the choice in Develop Assistant.)


Interestingly, if a batch job is run when the raw engine choice is Apple (not available to Windows users), then the raws are developed with the Apple engine and as if tone curve is enabled in Develop Assistant, regardless of whether it is or not, and then an additional brightening is applied.


Summary: a complete mess.






So is there a fix for this? I can of find it pointless to Batch Process JPEGs. All my workflows are always RAW files. :( Converting all my RAWs to JPEG before I batch would defeat the purpose. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.