Jump to content

Recommended Posts

Hi,  I just downloaded the 10 day free trial of Affinity Photo for Mac OS X.  My Mac meets the system requirements.  I am running 10.8.5.  16GB Ram.  2.8 GHz Core i7.   The download went smoothly and I dragged it to the Applications folder.  However, when I tried to open the program it first did a verification (no error message) then nothing happens.  When I double click on the Affinity icon in the Applications folder nothing happens there either.  I tried to reinstall but no luck with that.  Any suggestions?  I would really like to try it out before the trial ends.  Thanks!

Share this post


Link to post
Share on other sites

Hi Kenez,

Welcome to the forums.

 

Currently we are aware of an issue with the trial and OS X 10.7.5 and 10.8.5, this will be resolved when a new trial is released. At the moment we don't have a time frame on the release of the updated trial, but you'll be able to give the trial another go.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.