Jump to content
You must now use your email address to sign in [click for more info] ×

Export doesn't match content


Recommended Posts

Hi, 

When I export in pdf for print I lose parts of my image and the export also causes the image to drop down below the printer marks. What can I do to correct this? please see attachment for in program screenshot and after export with the data missing.

556656982_Bilde24_05.2023klokken15_22.thumb.jpg.f320a434f13b147b65ef7c5d7b3984ea.jpgimage.thumb.jpeg.46f7202e5925cde32a517b80acb07696.jpeg

Bilde 24.05.2023 klokken 15.23.jpg

Bilde 24.05.2023 klokken 15.24.jpg

Link to comment
Share on other sites

Hi @Khag and welcome to the forums,

Are you able to upload your Affinity file along with any linked images so we can take a look. Even just one page and it's associated image would be helpful.

If you're not able to do that then someone in the moderation team will be able to provide a private Dropbox link for you to upload your file to which you can request by replying to this post... :)

Affinity Designer 2.5.0 | Affinity Photo 2.5.0 | Affinity Publisher 2.5.0
Affinity Designer Beta 2.5.0.2486 | Affinity Photo Beta 2.5.0.2486 | Affinity Publisher Beta 2.5.0.2486

MacBook Pro M3 Max, 36 GB Unified Memory, macOS Sonoma 14.5, Magic Mouse

Link to comment
Share on other sites

Hi @Khag,

Everything is exporting as expected for me so at the moment I'm slightly baffled as to why you are seeing what you are seeing... It might be worth replacing both images in your file to see if that fixes the problem.

1471993408_PDFExport.jpg.a980d502294af41fdc679ea06e8483ff.jpg

 

Feilsøking intro.pdf

 

 

Affinity Designer 2.5.0 | Affinity Photo 2.5.0 | Affinity Publisher 2.5.0
Affinity Designer Beta 2.5.0.2486 | Affinity Photo Beta 2.5.0.2486 | Affinity Publisher Beta 2.5.0.2486

MacBook Pro M3 Max, 36 GB Unified Memory, macOS Sonoma 14.5, Magic Mouse

Link to comment
Share on other sites

Hi @Khag,

Could you embed the two images shown in your post above into your document rather than having them linked and then re upload the same file so we can check it's not something odd going on there...

For my test I replaced them with the two files you uploaded so I'd just like to check something odd isn't going on there.

Could you also confirm which version on macOS you are running?

Affinity Designer 2.5.0 | Affinity Photo 2.5.0 | Affinity Publisher 2.5.0
Affinity Designer Beta 2.5.0.2486 | Affinity Photo Beta 2.5.0.2486 | Affinity Publisher Beta 2.5.0.2486

MacBook Pro M3 Max, 36 GB Unified Memory, macOS Sonoma 14.5, Magic Mouse

Link to comment
Share on other sites

Hi @Khag,

The images in the file you've kindly just uploaded are still Linked... If you go to Resource Manager in Publisher, select each image in turn and then click on the Embed button along the bottom this will embed the original images.

If you could then re-upload that would be perfect... :)

Affinity Designer 2.5.0 | Affinity Photo 2.5.0 | Affinity Publisher 2.5.0
Affinity Designer Beta 2.5.0.2486 | Affinity Photo Beta 2.5.0.2486 | Affinity Publisher Beta 2.5.0.2486

MacBook Pro M3 Max, 36 GB Unified Memory, macOS Sonoma 14.5, Magic Mouse

Link to comment
Share on other sites

Hi @Khag,

Um, so there is absolutely nothing wrong with your file and for me it's exporting exactly as you would expect it to so I'm somewhat baffled as to why you're seeing the issues you are.

The only thing I can think to try is to reset Publisher to it's factory settings by starting it while holding the Ctrl Key on your keyboard and then clicking Clear in the Clear User Defaults dialog window.

This will mean that any changes you've made to your UI and tools palette will be lost so you will need to reset these again and equally that may also not fix the problem but there is no logical reason why your file isn't exporting correctly as far as I can see.

In your original screengrab it almost looks as though the image on page 2 is corrupted because of the grey noise appearing at the top but you've tried reloading it and I'm able to export the file without issue so I'd perhaps give the factory reset a go and let us know if it makes any difference and if not, hopefully one of the moderators can take a look to see if they can determine what could be causing the issue...

I wish I could be of more help but I'm struggling to think of anything else you can try...

 

 

Affinity Designer 2.5.0 | Affinity Photo 2.5.0 | Affinity Publisher 2.5.0
Affinity Designer Beta 2.5.0.2486 | Affinity Photo Beta 2.5.0.2486 | Affinity Publisher Beta 2.5.0.2486

MacBook Pro M3 Max, 36 GB Unified Memory, macOS Sonoma 14.5, Magic Mouse

Link to comment
Share on other sites

Hi @Khag,

Of Course, no problem at all...

If you could use Save as Package so everything is included and then let me know if there are any specific pdf settings you need to use for the pdf export that would be perfect, i.e., pdf version or preset, include the document ICC profile, with or without printers marks etc., then I'll export the file for you.

Affinity Designer 2.5.0 | Affinity Photo 2.5.0 | Affinity Publisher 2.5.0
Affinity Designer Beta 2.5.0.2486 | Affinity Photo Beta 2.5.0.2486 | Affinity Publisher Beta 2.5.0.2486

MacBook Pro M3 Max, 36 GB Unified Memory, macOS Sonoma 14.5, Magic Mouse

Link to comment
Share on other sites

Hi @Khag,

Thanks for the file, could you also upload FS Emeric Bold and Light which weren't included in the upload. It looks as though the text boxes using FS Emeric Light are hidden on the final layout and are therefore perhaps not relevant but FS Emeric Bold is still shown as the font used on the Page 10 heading 'Følg med på resultatene'.

There is also an issue with two of the placed pdf files which you will need to correct (on Page's 14 and 28)... First, they are shown as Linked rather than embedded (which means I don't have them) but they are also both shown with 'Original sizes of 0 px x 0 px' and 'Placed sizes of 0 mm x 0 mm'. This is a known bug in Publisher 2.0.4 usually resulting in the Publisher file not opening in 2.0.4 at all. The file opens in 2.1.0 but has actually just crashed on me as well. I'm unsure if this is due to the two Linked pdf files (which it shouldn't be) or for some other reason but it seems to reopen without issue (at the moment).

If you could replace the pdf's on those two pages, making sure they appear correctly and change them to embedded rather than linked and then re-upload your Publisher file along with the missing fonts I should then have everything required to be able to export your file for you.

1119002885_ResourceManager.thumb.png.130287b0c7b54ff96d871effcd5adc37.png

 

Your Publisher document uses an RGB/8 Colour Format with the sRGB IEC61966-2.1 Colour Profile... When exporting using the PDF for Print pdf preset, did you want the document to maintain those settings rather than CMYK settings, i.e., for the exported PDF to use Colour Space - As document and Profile - Use document profile?

1085193585_PDFExport.thumb.png.ee3e214a34fc15cd16d9260eb89f66e3.png

Affinity Designer 2.5.0 | Affinity Photo 2.5.0 | Affinity Publisher 2.5.0
Affinity Designer Beta 2.5.0.2486 | Affinity Photo Beta 2.5.0.2486 | Affinity Publisher Beta 2.5.0.2486

MacBook Pro M3 Max, 36 GB Unified Memory, macOS Sonoma 14.5, Magic Mouse

Link to comment
Share on other sites

1 hour ago, Hangman said:

could you also upload FS Emeric Bold and Light

From what I can see, those are commercial fonts which probably should not be uploaded. If there's a free version of them, I haven't found it at the usual places.

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
PC:
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.5, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.5

Link to comment
Share on other sites

14 minutes ago, walt.farrell said:

From what I can see, those are commercial fonts which probably should not be uploaded. If there's a free version of them, I haven't found it at the usual places.

Hi Walt,

@Khag can simply DM them to me or 'share' the Dropbox link via a DM and remove the live link in the post above. I couldn't locate a free version either, hence the request... :)

Affinity Designer 2.5.0 | Affinity Photo 2.5.0 | Affinity Publisher 2.5.0
Affinity Designer Beta 2.5.0.2486 | Affinity Photo Beta 2.5.0.2486 | Affinity Publisher Beta 2.5.0.2486

MacBook Pro M3 Max, 36 GB Unified Memory, macOS Sonoma 14.5, Magic Mouse

Link to comment
Share on other sites

Hi @Khag,

Many thanks for the two pdf files... I've relinked those and have exported your file using the PDF (for print) preset as requested...

The file exports without issue and with bleed in place throughout so I'm still somewhat baffled as to why the bleed isn't shown when you export the file.

Please give the attached file a thorough check to make sure everything is as expected and let me know if you spot any issues. The only small thing I spotted was the placed image on page 26 is quite low resolution, i.e., 114 dpi in the document but it seems to print okay so possibly nothing to be concerned about, though it would be very easy to recreate directly in Publisher.

When viewing the pdf in Acrobat Reader I'm seeing hairlines on the top left edges (in the bleed area) on Pages 7 and 15 which seem visual only in as much as I tweaked the grey and white boxes making them wider hoping they wouldn't appear but it makes no difference to the output but regardless, the hairlines don't appear when printing those pages.

Any problems or issues please let me know... I'm hoping someone from the moderation team may have some thoughts as to why the pages are printing without bleed in certain circumstances  for you as it makes little sense...

I hope this helps... :)

Roede velkommen intro program.pdf

Affinity Designer 2.5.0 | Affinity Photo 2.5.0 | Affinity Publisher 2.5.0
Affinity Designer Beta 2.5.0.2486 | Affinity Photo Beta 2.5.0.2486 | Affinity Publisher Beta 2.5.0.2486

MacBook Pro M3 Max, 36 GB Unified Memory, macOS Sonoma 14.5, Magic Mouse

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.