Jump to content
You must now use your email address to sign in [click for more info] ×

Expand stroke makes it disappear


Recommended Posts

When I expand a stroke, sometimes it just disappear. BUT.

The curve is still in my layers list, but it doesn't appear inside my work area. The curve can be selected in the layers list, but in the transform panel, it doesn't have width or height.

The curve isn't moved somewhere else, it doesn't appear anywhere.

 

Capture d'écran 2023-05-11 124938.png

Capture d'écran 2023-05-11 125042.png

Capture d'écran 2023-05-11 125114.png

Link to comment
Share on other sites

45 minutes ago, Dan C said:

HI @GenewalDesign,

Thanks for your report!

Are you able to please provide a copy of this document with the curve before it has been expanded? If you wish, this can be a 'cutdown' file with only the affected curve(s) present.

Many thanks in advance :)

Hey Dan, here is the file. Thanks for your help

curve-expand-problem.afdesign

Link to comment
Share on other sites

  • Staff

Thanks for providing that for me!

I've tested this in both 2.0.4 and 2.1 beta and unfortunately the issue is present in both versions - this bug appears to be caused by the Pressure Profile applied to the curve, as removing this allows the shape to be expanded as expected.

I'll be logging this as a bug with our developers now, I hope this helps :)

Link to comment
Share on other sites

12 minutes ago, Dan C said:

Thanks for providing that for me!

I've tested this in both 2.0.4 and 2.1 beta and unfortunately the issue is present in both versions - this bug appears to be caused by the Pressure Profile applied to the curve, as removing this allows the shape to be expanded as expected.

I'll be logging this as a bug with our developers now, I hope this helps :)

I hope I won't drive back the 2.1 release 😅

Link to comment
Share on other sites

7 hours ago, Dan C said:

his bug appears to be caused by the Pressure Profile applied to the curve, as removing this allows the shape to be expanded as expected.

We don't have to remove it, just raise up the start end to something non zero. Having said that, I would think this is a bug.

Mac Pro (Late 2013) Mac OS 12.7.2 
Affinity Designer 2.3.1 | Affinity Photo 2.3.1 | Affinity Publisher 2.3.1 | Beta versions as they appear.

I have never mastered color management, period, so I cannot help with that.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.