Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Recommended Posts

Ever since upgrading to v2 I've been having issues with Snapping to Nodes and Object Geometry being inconsistent and I can't replicate why.

I primarily work with Affinity Publisher v2 going between the Publisher and Designer Personas.

It seems to be a per-document issue as the universal settings remain unchanged. Doesn't matter if it's a document created with v1 and saved to v2, created in v2. I can create a new document and sometimes objects and nodes snap as expected, sometimes they don't. And I can copy the elements from a document that isn't working correctly, into one that is, and they behave correctly. 

Can someone confirm if this is a bug or perhaps I'm missing a setting in v2.

Affinity v2 Snapping Bug.gif

Link to comment
Share on other sites

I was able to replicate this issue on Windows 10.
Same snapping options (as far as I can tell) set in V2 and V1 but there is a difference in the result of dragging.

Some issues have been reported regarding selecting nodes in Publisher under certain conditions so maybe this snapping issue is related to the selection issue.

Link to comment
Share on other sites

11 hours ago, Andrew OBrien said:

perhaps I'm missing a setting

  • When snapping with the Node tool and using only its snapping options in the context toolbar while the global "Snap to object geometry" option is disabled, both objects must be selected.
  • With "Snap to object geometry" enabled, the other object doesn't have to be selected, and the context toolbar snapping option doesn't have to be enabled either.

You may want to keep the View > Snapping window open and experiment with all those various options.

It's the same for v1 and v2.

Link to comment
Share on other sites

3 hours ago, loukash said:
  • When snapping with the Node tool and using only its snapping options in the context toolbar while the global "Snap to object geometry" option is disabled, both objects must be selected.
  • With "Snap to object geometry" enabled, the other object doesn't have to be selected, and the context toolbar snapping option doesn't have to be enabled either.

You may want to keep the View > Snapping window open and experiment with all those various options.

It's the same for v1 and v2.

The issue is, this is a global setting and it's enabled. The attached gif shows moving from one document to another with no changes and it doesn't work.

Your second bullet is enabled in both instances but in the first it does not work. And I agree it should be the same in v1 and v2 but it's not behaving the same.

Link to comment
Share on other sites

9 hours ago, GarryP said:

I was able to replicate this issue on Windows 10.
Same snapping options (as far as I can tell) set in V2 and V1 but there is a difference in the result of dragging.

Some issues have been reported regarding selecting nodes in Publisher under certain conditions so maybe this snapping issue is related to the selection issue.

I've also intermittently had this issue where you cannot bulk select nodes. I haven't done much research on it as I can't reproduce the issues as to why. Sometimes quitting and re-opening fixes the issue (unlike this snap to geometry issue).

Link to comment
Share on other sites

13 hours ago, Andrew OBrien said:

I've also intermittently had this issue where you cannot bulk select nodes.

I think the bulk-selection issue may be something to do with multi-page documents but Serif are definitely aware of it and it’ll hopefully get fixed with the next update, whatever the cause.

Link to comment
Share on other sites

  • Moderators

Hi @Andrew OBrien welcome to the forums,

I had initially thought this was connected with the node selection issue when there is >1 page in the Publisher document, however this issue is resolved in the latest beta release i'm still able to replicate this issue with snapping intermittently between documents.

I've now logged this with the developers, thanks for providing detail.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.