Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Spell correction not working


Recommended Posts

  • 2 weeks later...
  • Moderators

@firstnose Sorry for the delay, we're very busy at the moment. From the Text studio, tap the > opposite the bold, italic options to switch to the the Character section. Then select Language, here you can set the available spelling and hyphenation.

It's worth nothing the listed languages are the only ones available, the iPad version cannot have any additional ones added.

Link to comment
Share on other sites

Hello.

Thanks for your answer.

It seems not to work…..

 

Steps:

1. -> Text Panel (Studio is the same, no?) -> Language:

- I’ve selected « French (France) »: it doesn’t change anything in Preflight control (I’ve even played with default/Latin/French choices for hyphenation and spelling).

- it is the same if I choose « none » as language (with default or auto for hyphenation and spelling).

Remark: you’ve said that «It's worth nothing the listed languages are the only ones available, the iPad version cannot have any additional ones added ». should have the same rules, dictionary and so on. Are you speaking about Publisher or iPadOS? About iPadOS, I would suppose that for orthography, Français-France, Francais-BE(lgique) and Français-CH (Switzerland) should have the same rules, dictionary and so on (is it the same for Français-Canada?). But those countries use different keyboard setup, and this option is recorded in system preferences (France: AZERTY  - Belgium: AZERTY with special accents places - Switzerland: QWERTZ).

Would it be possible that there is the problem? Not linking these particular keyboard setups to dictionaries or something like that?

—————————————-

2. Preflight Control Panel: always overpopulated with « Missing Dictionnaries for language (fr-CH) » messages

I’ve tried to modify Profiles of this section: if I suppress orthography control, then no more errors messages (purely esthetic, but loosing a function).

⚠️ Doing this, I’ve noticed what is perhaps another bug (perhaps related, so I’ll mention it here):

when you choose the « Modify Profile » option and modify it (only tried with orthography option), then changes are not recorded.

- sort of confirmed by the fact that when you’ve closed the « Modify Panel » (options), the Profile name (preset) shown in Preflight Panel’s designed box is no more this profile’s name, but «<personalize>».

 - What I noticed is that at the moment of the creation of a new Profile, it doesn’t let you choose options but creates this profile with the settings effective at the moment. So,  « modify » doesn’t record changes, but as a workaround, you could select a profile, modify and close it. At said here above, at that moment the Profile’ s name in the box will no more be the name of this particular profile, but « <personalize> ». ⚠️ if at this step you create a new profile, it will keep all the changes you’ve made just before.

In summary, not possible to modify a Profile, but you can have a new one keeping changes you’ve made with this method.

 

Regards.

 

 

 

Link to comment
Share on other sites

16 minutes ago, Macmat said:

1. -> Text Panel (Studio is the same, no?) -> Language:

- I’ve selected « French (France) »: it doesn’t change anything in Preflight control

This setting should serve as a default for a text frame that does not have any text in it. However, if the frame already has text, you would need to select that text to change its Language settings. Or, you would need to change the Language for the Text Style that you've applied to the text.

Does that help explain what you're seeing?

-- Walt

Desktop:  Windows 11 Home, version 21H2 (22000.613) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 
Laptop:  Windows 10 Home, version 21H2 (19044.1706) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
        Affinity Photo 1.10.6 (.1665) and 2.0..3  and 2.0.3.1670 beta/ Affinity Designer 1.10.6 (.1665)  and 2.0.3 and 2.0.3.1670 beta / Affinity Publisher 1.10.6 (.1665)  and 2.0.3 and 2.0.3.1670 beta
iPad Pro M1, 12.9", iPadOS 16.3, Apple Pencil 2, Magic Keyboard

      Affinity Photo 1.10.6 and 2.0.3 / Affinity Designer 1.10.6 and 2.0.3 / Affinity Publisher 2.0.3

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.