Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Affinity Photo closing during batch job - no error messages

Recommended Posts

Affinity Photo Version

Application simply closes down  after saving a couple of images during batch job. No messages. Happened each time I have tried.

Batch job is to convert .CR2 to .jpeg (saved in as different folder).

Successfully processed many more images under version 1.9 (though didn't always process every one (sometimes hundreds).

[post note edit - seems to work OK if parallel processing switched off]

Edited by Martin Brady
Further info.
Link to comment
Share on other sites

Just a simple macro to apply auto contrast and sharpening. I think you might be on to something with the RAW files (in my case Canon .CR2). By way of a test I just put 82 jpegs through with parallel processing on, applying the macro and converting them to Tiff files and there were no problems, in fact very fast. (N.B. as per my added note, I did discover that the RAW files went through OK if parallel processing was turned off).


Link to comment
Share on other sites

  • 2 months later...

If it helps with debugging.  I also had difficulties with Batch processing in parallel.  I was converting CR2 files to JPEG with no other macros or image enhancements; just a straight conversion.  The CR2 images were created with the Canon EOS Rebel T5i.  Pictures were taken in 2016.  The dimensions are 5184 x 3456 (about 24 MB each).

I have your basic HP 450 G5 with 8GB RAM.  4 Cores and 8 processors.

I selected 65 files for the conversion.  The originals and output folders were on another machine on the LAN.  I mapped drive "S:" to that remote storage location.

When I started the process, PHOTO started converting the first 8 files (guessing it was loading up one photo per processor).  The machine became unresponsive with 10 seconds, mouse would not move, task manager froze, etc.  The "processing" indicators beside the files froze as well.  Task Manager froze as well.  After what seemed like a couple of minutes.  PHOTO just shutdown with no messages on the screen.

I checked Windows Event viewer and it contained the following error in the Application  logs:

Faulting application name: Photo.exe, version:, time stamp: 0x617b14a3
Faulting module name: igdrcl64.dll, version:, time stamp: 0x5f8743e8
Exception code: 0xc0000409
Fault offset: 0x000000000026c389
Faulting process id: 0x4d2c
Faulting application start time: 0x01d7e3e64e5fcfd8
Faulting application path: C:\Program Files\Affinity\Photo\Photo.exe
Faulting module path: C:\WINDOWS\System32\DriverStore\FileRepository\igdlh64.inf_amd64_e6daaea9afe1e6f6\igdrcl64.dll
Report Id: 2291a618-c007-4bfa-bafd-1de36ac1390f
Faulting package full name:
Faulting package-relative application ID:

The event ID = 1000

Locale ID: 4105

As a note I am running windows 10 PRO 21H2 OS build 19044.1348  experience pack 120.2212.3920.0.

As a note, there was no file actions in the output folder. 

I tried this a couple of times.  The first was my first attempt at using this feature.  The second was with task manager on, which did not help because the whole machine was freezing up.

I tried a third time but with only 4 files and task manager on.  The process completed in about 4 minutes.

In Task Manager noticed that in the first 2/3 of the time my Local SSD drive was at 100%, and memory usage was at 7.5/7.7, CPU usage was peaking at 50-60% .  Then during the last 1/3 local SSD usage went way down, memory usage when to 5.3/7.5 and CPU usage went to 100%.  Mouse movement and Task Manager became jittery.

The process completed with the four files being converted to JPG.  I tried to repeat the process with the next 4 files.  This time the PHOTO terminated after being at 100% CPU utilization for a minute in what seems as the second stage of processing.

I really like this application and what to see it "take over the world".  I can provide you with CR2 files if you need them.

Link to comment
Share on other sites

  • 2 weeks later...

I encountered the same problem issues with files in local storage.  No macros were running.

Since then, I updated to Windows 11 and added another 8GB to my machine for 16GB total. The parallel batch job worked fine with files locally and for accessing files on the network and exporting them locally.  I got 2 failed files during the export out of 30 files when running both import and export on the network.


Edited by SMagsCAN
Provide more info
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.