Jump to content

Live perspective filter broken on artboards


Recommended Posts

Some of my artboards are broken.  Not sure if this is related to update to 1.10, but had not noticed earlier.

I found with some experimentation I can reproduce the result by simply duplicating the artboards.

In the attached file, all artboards are identical, but they look different.  Some look blank.

If you start duplicating them, you will see that some will be distorted or blank.

 

broken-perspective-filter.afpub

Link to comment
Share on other sites

If they had, there would be a response.

Quick question: what application are you using?

You've posted in Designer Bugs, but you've provided a Publisher file.

-- Walt

   Desktop: new:  Windows 11 Home, version 21H2 (22000.613) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090  (old: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970 )
   Laptop:  Windows 10 Home, version 21H2 (19044.1706) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
    Affinity Photo 1.10.5 (.1342) and 1.10.5.1342 Beta   / Affinity Designer 1.10.5 (.1342) and 1.10.5.1342 Beta  / Affinity Publisher 1.10.5 (.1342) and 1.10.5.1282 Beta
 iPad Pro M1, 12.9", iPadOS 15.4.1, Apple Pencil 2, Magic Keyboard

  Affinity Photo 1.10.5 (.280) and 1.10.2 (.266) Beta / Affinity Designer 1.10.5 (.21) and 1.10.3 (.19) Beta 

Link to comment
Share on other sites

  • Moderators

Hi @CMO,
This is happening because you are copy/pasting the text and nested filter to the other artboards and although they are copied to the new artboard, the grid/control of the perspective filter remains in the original artboard where it was copied from. You can check this if you select the text layer in the Layers panel of one of the artboards where it doesn't display (you should see the blue bounding box appearing on the canvas/artboard - the text itself remains invisible) then double-click the perspective filter layer nested to that text object  in the Layers panel - if you look at the canvas now you should see the perspective/grid control over another artboard (the one from where the objects where originally copied from). I'm logging this to be looked at.

Link to comment
Share on other sites

5 minutes ago, MEB said:

I'm logging this to be looked at.

Thanks. 

It seems to me there have been a number of bugs that seem related to using multi-artboard documents in Photo (and possibly the Photo Persona of Publisher) that all seem to involve improper binding of effects, filters, Fill or Pixel layers to the right Artboard. That might be an area to focus some testing on.

-- Walt

   Desktop: new:  Windows 11 Home, version 21H2 (22000.613) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090  (old: 16GB memory, Intel Core i7-6700K @ 4.00GHz, GeForce GTX 970 )
   Laptop:  Windows 10 Home, version 21H2 (19044.1706) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
    Affinity Photo 1.10.5 (.1342) and 1.10.5.1342 Beta   / Affinity Designer 1.10.5 (.1342) and 1.10.5.1342 Beta  / Affinity Publisher 1.10.5 (.1342) and 1.10.5.1282 Beta
 iPad Pro M1, 12.9", iPadOS 15.4.1, Apple Pencil 2, Magic Keyboard

  Affinity Photo 1.10.5 (.280) and 1.10.2 (.266) Beta / Affinity Designer 1.10.5 (.21) and 1.10.3 (.19) Beta 

Link to comment
Share on other sites

  • 4 months later...

Is there any update on this issue?  I have not been able to find a work around.

I have a lot of work using perspectives that I need to make new variations and there is no way to copy the original work.  I can't do a pixel perfect new version as I have to redo the perspectives from scratch.  This is very painful and time consuming.

Link to comment
Share on other sites

Note, this is broken everywhere, not just Artboards.  I also can not properly create copies in photo.  You can create one copy, but once you make further copies they also break.  Is this issue being investigated?

Link to comment
Share on other sites

  • Moderators

Hi @CM0,
Yes, we are aware this is broken when duplicating artboards and duplicating objects with the live perspective filter applied (in all apps). Both issues are logged/being investigated but i can't give you an eta for a fix. It depends entirely on management/development priorities, sorry.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.