Jump to content

Plugin won't launch


Recommended Posts

  • Moderators

Hi @PGPhoto,
Welcome to Affinity Forums :)
To what plugins are you referring exactly? Nik Collection 4? It's the exact same thing with Photoshop. If the plugins were NOT optimised for M1 the only way to run them is to force the host app to run in Rosetta mode (emulation).

Link to comment
Share on other sites

  • 1 month later...

Hi Meb, thanks. Do I understand correct, you suggest to authorise access to / (root)? - I've been working for 15 yrs als Unix sysadmin and that workflow makes me nightmares.

I tried also the DxO page you suggested and I got (copy & paste of the link you posted below https://help-nikcollection4.dxo.com/install_activate):

2021-11-09_22-29-15.thumb.jpg.660c2f7c2640d5242331a4e9c456785b.jpg

(This forum editor urgently needs the ability to resize images 😆)

This plugin thing turns out to be a "crackling nut". - (I have no clue how to translate this into English. In German it's "Knacknuss", an artificial word, put together of "knack/crack" and "Nuss/nut" - Because some nuts suppose to be cracked only very hard, the meaning is a problem hard to be solved).

On 8/31/2021 at 2:17 PM, MEB said:

Hi @Roland Rick,
I will let you know if/when i receive a reply from them.
I have Luminar 4 and Ai here but never tested them with Affinity Photo. Make sure you give Affinity Photo root access: click the Authorise Global button once in Affinity Photo, Photoshop Preferences section, then press the Authorise button again in the Finder window that will open next - you should see a forward slash in the first line in the Plugin Supports Folder section. Remove all the others you may have added there since they are not required if you give Affinity Photo root access). Also make sure you have Allow "Unknown" plugins to be used ticked. In any case i will install and check them myself too.
Regarding Nik Collection, i don't have the latest version (didn't updated to 4 yet) but i know that some Nik Collection 3 plugins do work with Affinity Photo MAS version (Viveza however crashes consistently in the MAS). I don't mind updating mine to check this also.

Meanwhile DxO have installation instructions specifically for Affinity Photo here (scroll down up to the Installing Serif Affinity Photo* section) that may help you out.

Roland Rick

Roland Rick Photography
Pipobike Mountainbike Guide and Driving Instructor

iMac 27 5K Retina (Late 2013), MBP 15" Retina (Something 2013), MBP13" Retina (Early 2015)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.