Jump to content

v192 Pixel layer > Group > Fill Color > ...?...


Recommended Posts

What is going on here: When I apply a fill color to a "(Group)" layer containing a "(Pixel)" layer then …

• the pixel image entirely disappears + gets replaced by plain color
• its initial size gets set to spread size (even though there is only a left page).
• if scaled before then its new size caused by colorizing becomes even larger than the spread.

Also odd: When I color a "(Group)" layer which contains an image layer then both layers, the group + the image layer, get the fill applied.
When I move the image layer out of the group then …

• the empty "(Group)" layer is indicated maintaining its fill applied. When I then move an image layer which has no fill applied into the group then …
• the "(Group)" layer still seems to have the color applied but doesn't display it in the page layout.

346239618_groupedimagefillcolor.thumb.jpg.5c466c0ada0da2bd508540a5c60f530d.jpg

 

macOS 10.14.6, Macbook Pro Retina 15" + Eizo 27" // Affinity preferred in Separated Mode + Merged Windows

Link to post
Share on other sites
5 hours ago, thomaso said:

When I apply a fill color to a "(Group)" layer containing a "(Pixel)" layer then …

• the pixel image entirely disappears + gets replaced by plain color

Technically you are painting on the pixel layer.
From what I've observed so far, applying a fill to a pixel layer is the equivalent of the Flood Fill tool.
Applying a fill to a group of layers floods all children.

It feels a bit weird at times, and there seem to be some glitches every now and then, but all in all it seems to behave consistently. It's slightly more comprehensible in the Photo persona where you have more pixel tools and context toolbar options.

Link to post
Share on other sites
3 hours ago, loukash said:

applying a fill to a pixel layer is the equivalent of the Flood Fill tool.

While Flood Fill Tool vs. APub fill color have in common that they fill a "(Group)" layer in the entire document dimensions or even larger, I experience them as similar – but not as equivalent.

APh's Flood Fill Tool behaves different to me, mainly because it allows to apply a fill color to the pixel layer itself (what APub fill doesn't and therefore a group might be used). Accordingly a bucket fill applied to a pixel layer remains within its object bounding box. Also the Flood Fill Tool doesn't work on a "(Group)" layer, instead it needs to click a color well or swatch (like in APub).

Actually I would not expect such behaviors from a "(Group)" layer but rather from a rasterized "(Group)" layer or a "(Layer)" layer only.

Another confusion occurs when I click a color + set its opacity slider, then the "(Group)" layer doesn't react on the opacity previewed in the color well – though the Transparency Tool maybe used to set the opacity of this fill color.

923719322_grouplayercoloropacity.thumb.jpg.b08c6047329ddb59c9a61369ba4928e1.jpg

macOS 10.14.6, Macbook Pro Retina 15" + Eizo 27" // Affinity preferred in Separated Mode + Merged Windows

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.