Jump to content
Lurri90

Photo, horrible performance.

Recommended Posts

Hi, I recently formatted my PC and installed the latest Affinity Photo.

When I hover the mouse over the tools it's like the program grinds to a halt, mouse starts lagging over the UI, 5 fps style.

It's worse the heavier the tool I'm using, e.g. if I use gradient tool it lags even more and eventually crashes.

I'm running Ryzen 3900x and RTX 3080, should make light work of a photo program.

I also tried previous version but it's the same behavior.

It was fine on this computer when using some older version I can't remember. I thought it was fair to let you know that is happening in the latest versions.

Should I got back to some 1.7.xx version?

Edited by Lurri90

Share this post


Link to post
Share on other sites

Just tried 1.7.3 and the issue still persists, now tried 4 different versions.

Could this be some AMD or Nvidia related bug. The program was fine when I used it on an RTX 2070S.

Edited by Lurri90

Share this post


Link to post
Share on other sites

I would check that the Renderer in Preferences of Affinity Photo is set to the GPU.
Next thing would be to reinstall drivers, even if its the same brand, changing and upgrading the GPU should always be accompanied with reinstalling the drivers.


gumroad.com/myclay | timurariman.com
Windows 10 Pro - 20H2 | Ryzen 2700 | NVIDIA GeForce GTX 1080ti 11GB  | 64GB |
Samsung SSD 860 EVO 500GB | Crucial MX500 1TB | WD Black PCIe SSD 256GB (configured as Scratch disk) |

 

Share this post


Link to post
Share on other sites
8 minutes ago, myclay said:

I would check that the Renderer in Preferences of Affinity Photo is set to the GPU.
Next thing would be to reinstall drivers, even if its the same brand, changing and upgrading the GPU should always be accompanied with reinstalling the drivers.

I'm such a nerd that I reformat the entire system if I install something new like a GPU :)

The renderer was set to the GPU, however setting it WARP fixed it (I'm guessing that's CPU).

Next time Nvidia comes out with new drivers I'll try switching back to GPU and see if it's better.

 

Edited by Lurri90

Share this post


Link to post
Share on other sites

woha neat.
It might be possible to switch back from Warp to the GPU now since it would trigger the GPU again.

The Customer Betas (Release candidate 2) should be much faster for Windows systems than the older versions, there is an Hardware acceleration option to enable OpenCL compute acceleration and there is a benchmark tool integrated which resides under Help and then Benchmark.


gumroad.com/myclay | timurariman.com
Windows 10 Pro - 20H2 | Ryzen 2700 | NVIDIA GeForce GTX 1080ti 11GB  | 64GB |
Samsung SSD 860 EVO 500GB | Crucial MX500 1TB | WD Black PCIe SSD 256GB (configured as Scratch disk) |

 

Share this post


Link to post
Share on other sites

I have had nothing but problems with the 1.9 update. Focus merge does not work correctly when I am utilizing 2 screens. It crashes and blinks my screens out. Comes back on to sit indefinitely halfway through the merge process. So frustrating! Never had a problem with the software until the update. I went through the different tutorials and changed settings back and forth. The best solution was to turn off my second screen while doing focus merge. Please fix this. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.