Jump to content

Recommended Posts

Yes, not one of the best places, but where to post else? Yes, this was reported before, but was never never fixed in the years before. Take it as a small reminder. It is a bug for sure, everyone saying this is a feature request is COMPLETELY WRONG.

One of the things annoying me from when I started using Affinity: Affinity is (partly) not capable to memorize colour assignments from Swatches. Two examples ...

1. There is a rectangle filled with colour RED from the Swatches panel and there is a line with a stroke colour of GREEN from the Swatches. Now click the rectangle and look at the Swatches panel. Say you had luck and the Fill Colour Icon was on top, Swatches panel shows you the colour RED. Fantastic! Now click the line and switch to the Line Colour Icon (Swatches panel) and look at the Swatch Panel ... no colour is selected in the Swatches Panel. Mediocre!

2. Even worse: Say you define a drop shadow for an element. Select and click the colour from the Swatches panel. The colour assignment is instantly deselected VISUALLY. Yes, the assignment worked, but what colour was selected from the Swatches panel? Same applies to gradients.

So the current workflow for Example 1 is: Switching the Fill / Stroke Colour Icons in the Swatches panel BEFORE I get the information which colour was used. One could say of course that I have to know my colours. No problem, if there are only a few distinguishable colours, but what if you have a lot of similar looking colours in the Swatches panel? Aside to that, lately I had a document converted from a PDF with loads of B/W drawings with fills and strokes. 50 % of them had a correct black colour assignment, for the other 50 % I was switching Fill / Stroke icons, clicking, deselecting ... No fun.

So please dear developers ...

Share this post


Link to post
Share on other sites

Hi @Joachim_L,

On 7/30/2020 at 9:03 AM, Joachim_L said:

1. There is a rectangle filled with colour RED from the Swatches panel and there is a line with a stroke colour of GREEN from the Swatches. Now click the rectangle and look at the Swatches panel. Say you had luck and the Fill Colour Icon was on top, Swatches panel shows you the colour RED. Fantastic! Now click the line and switch to the Line Colour Icon (Swatches panel) and look at the Swatch Panel ... no colour is selected in the Swatches Panel. Mediocre!

 I'm not entry sure I follow you on this. Have you got a screen recording?

Share this post


Link to post
Share on other sites
13 minutes ago, Gabe said:

I'm not entry sure I follow you on this. Have you got a screen recording?

Sure, here you go. One thing differs in the video, there are no names for the colours in the Swatches panel. But this is not relevant.

Share this post


Link to post
Share on other sites

I'm afraid this is not a bug. The stroke/fill should not change when you select a different shape, so it's acting as designed. I moved this to feature requests. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.