Jump to content

Affinity Designer (1.8.3) can't type Japanese texts on Catalina(10.15.1).


Recommended Posts

I have same problem on MacBook Pro (16-inch, 2019) - Affinity Designer 1.8.3 - Mac OS Catalina 10.15.5.

But, there's no problem on my old one: MacBook Pro (Retina, 13-inch, Late 2013) - Affinity Designer 1.8.3 - Mac OS Mojave 10.14.6.

I suppose there's some compatibility problem with new Magic Keyboard. If possible, please check on MacBook with new Magic Keyboard.

Link to comment
Share on other sites

  • Moderators

Hi kage,

As you've seen we've had this reported a few time, but we've never been able to replicate it - even using an Apple USB JIS keyboard. Unfortunately due to the current situation I don't have access to that keyboard right now. Even with that we still don't have access to a 2019 Japanese MacBook Pro.

Would you be able to attach a screenshot of the System Preferences > Keyboard > Input Sources section on both the 2019 and 2013 MacBook Pro please? If you enable an on-screen keyboard does it work if you click the button on the on-screen keyboard?

Link to comment
Share on other sites

  • 2 weeks later...

Hi Sean,
Thank you for your reply and I solved the problem. 

I compared the settings on my old and new MBP.
Then, I turned on "Romaji" Input Mode over Japanese Input Source, Affinity Designer works correctly.

Compare.png

Link to comment
Share on other sites

I found out that if I don't remove the English input mode as well, it doesn't work properly when the input mode is set to ABC (English).
Other softwares like Adobe Illustrator, works properly with the original settings (ABC(English) + Japanese("Romaji" is off)).

Compare2.png

Link to comment
Share on other sites

  • 1 month later...
  • Moderators

Hi kage,

Sorry for the extremely late response. I've finally been able to get hold of our JIS keyboard again and with your help I've been able to reproduce the issue exactly as you say. Using 'Romaji' in the Japanese keyboard and everything is fine, however if I add the 'ABC' keyboard and then disable 'Romaji' for the Japanese Layout it stops working in our application.

I'll get this passed on to development to be investigated. Thanks again for your help!

Link to comment
Share on other sites

  • 3 months later...

Hello,

It looks like this happens on 1.8.6 on macOS 11.1 on Mac mini (M1, 2020).

In the System preference > Keyborad > Input Sources, I had to turn on 英字 on 日本語 – ローマ字入力’ keyboard, shown on the image attached, and then, delete the ‘ABC’ keyboard to solve the issue.

The first attached image shows the initial state. The second one shows the state where I changed the setting and deleted ‘ABC’ keyboard.

I hope this gets fixed in the future release! Thank you for your help as always.

keyboard-input-sources-mac-mini-m1-2020.png

keyboard-input-sources-mac-mini-m1-2020-after-fix.png

Link to comment
Share on other sites

  • 1 month later...
On 9/10/2020 at 5:46 PM, Sean P said:

Hi kage,

Sorry for the extremely late response. I've finally been able to get hold of our JIS keyboard again and with your help I've been able to reproduce the issue exactly as you say. Using 'Romaji' in the Japanese keyboard and everything is fine, however if I add the 'ABC' keyboard and then disable 'Romaji' for the Japanese Layout it stops working in our application.

I'll get this passed on to development to be investigated. Thanks again for your help!

Hi I have this issue, even with the latest 1.9ver of the affinity app.
It's a shame because I actually really like the app. I still like the app,,, but this is an inconvenience for me.

Really hoping this gets fixed in the near future. Please.
No app that I have ever used, free or otherwise, has had this issue...
(Also I know this is another topic, but having the option for vertical Japanese text input will also be fantastic)

 

The work around shown above, causes issues(more an inconvenience, sure...) for another particular app that I have.
So I do not want to remove the ABC input, if possible.
(Also, sometimes the language toggle keys act as a space button(but not always))


<Other workarounds>
For anyone else trying to find a workaround WITHOUT removing the English ABC keyboard, here are 2 ways I have found. (Using Mac with the Mac App Store version of affinity publisher)

1, In the keyboard settings under system preferences, check a box at the bottom that lets you toggle input from ABC with the caps lock key.
You can still toggle caps lock by holding the key.

2, It’s likely set by default, but a shortcut 
“cmd + space” 
let’s you toggle the input language.

Neither of these workarounds are great... but they work in affinity publisher(have not tested on other affinity apps). They cannot compete with the convenience of having a dedicated button for each Japanese, and English(or other languages if that is what you have), not to mention the inconvenience this causes, because you're used to using the actual toggle buttons for every other app, but these options kinda work, if the you don’t like the original workaround above.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.