Jump to content

Recommended Posts

Good day,

I found that the preview of applying filters in develop persona is not consistent over the image, the filters being applied partially, please see the attached images.

The filter is correctly applied on the exported image, the problem exists in the develop persona, when editing the image.
I am using Affinity Photo 1.8.3.180. This bug does not exist on MacOS.

Love Affinity Photo, keep up the good work!

8B84A2C2-02E1-4C24-9D9F-C0D5F110BD6C.jpeg

A11CA964-0413-4FF5-A3A4-6FC0AC44DB0C.jpeg

C368F533-B8FE-4018-B7E3-81FF9243797D.jpeg

33AF4FCD-63BA-4ABC-97C0-1AD3794B39AA.png

_7R30006.jpg

7FA53173-6898-4771-B0F5-93F6806C82FA.png

Share this post


Link to post
Share on other sites

Hey ovisan,

To clarify, you mean you apply a live filter and then return to the Develop Persona to perform further edits, with the live filter enabled?

I cannot reproduce this. I've tried with Halftone and Unsharp Mask. 

Can you attach a document?

Share this post


Link to post
Share on other sites

Hi Chris,

Please load the attached jpg and apply the halftone live filter to it. To reproduce the bug please zoom in, release, zoom out, release... repeatedly and after a few tries you should see the bug.

I tried to also upload a raw ARW file 85MB, but I get a -200 error. Nevertheless, the bug shows also with this jpg. Also i made 2 recordings to better illustrate the bug.

Let me know if i can help.

835F6C35-0076-4BA3-B8D3-0AE50B64F283.png

_7R33488.jpg

Share this post


Link to post
Share on other sites

Hey ovisan,

I see what you mean. The issue is more apparent when using a smaller Cell Size. I set it to 2.0 as seen in your screenshot and the problem appeared instantly.

I thought it might be a 100% view mipmap thing but the filter redraws and looks different at a number of different views. I'll pass this over :) Thanks for replying! 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.